Mustang Evolution Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
420 Posts
Discussion Starter #1
I've noticed the past few days my car idles really high, sometimes when I put it in neutral it'll get up to 3000 rpm when coasting to a light then it'll slowly drop down, and while siting at idle it idles at around 1100-1300 rpm
Could this be my idle air control or a vacuum leak somewhere?
 

·
Registered
Joined
·
1,563 Posts
Clean your MAF sensor first see how that works. If that doesn't work then clean TB.
 

·
Registered
Joined
·
502 Posts
As long as you use throttle body an intake cleaner and NOT carb cleaner it will be fine but not while the car is running
 

·
Registered
Joined
·
1,563 Posts
As long as you use throttle body an intake cleaner and NOT carb cleaner it will be fine but not while the car is running
^+1

I just did my TB with it on. It will start kinda weird rpm fluctuate for a few seconds, but then everything is normal.
 

·
Registered
Joined
·
525 Posts
Rap on the IAC with that back of a screwdriver or something similiar while its running high at idle,,see if it doesnt bring the idle down,,sometimes if the IAC is stuck when you tap on it ,,the idle will come down
 

·
Registered
Joined
·
1,563 Posts
What would carb cleaner do?
Well some Ford throttle bodies are coated and the agressive agents in those solvents will dissolve the finish and ruin the throttle body. :(
 

·
Registered
Joined
·
420 Posts
Discussion Starter #14
Now when I push the clutch in the rpm climbs On It's own, and when coasting in gear it will keep the car going instead of slowing down
 

·
Registered
Joined
·
1,563 Posts
Now when I push the clutch in the rpm climbs On It's own, and when coasting in gear it will keep the car going instead of slowing down
Tell us what you did to it?
 

·
Registered
Joined
·
292 Posts
Mine did this after i got it tuned. Idk why, but it slowly got better.
 

·
Registered
Joined
·
280 Posts
My car did this when i had a bad splice on the tps harness after a windstar swap. After the solid cleaning of everything and a once over on all the vac lines if the problem still persists check the tps cuz maybe it's going bad also check to see if theres anything causing the butterfly not to close properly.
 
1 - 20 of 21 Posts
Top