Mustang Evolution Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
1,405 Posts
Discussion Starter #1
Ok so last night coming home from work.. Driving 45 mph in a 55 tried to pass someone that was going too slow.. I almost had to back off. My car was acting like it was towing a house... I could NOT get it past 70mph without SLAMMING the gas to keep it from downshifting.. (When it shifts into 5th its useless" and its like its shifting into 5th before I'm even to 40mph damn autos!!! Tune issue? Or possibly something more serious?

---------- Post added at 07:21 AM ---------- Previous post was at 07:19 AM ----------

I'm taking it by the shop Saturday to get a good checking over. I just wanted to throw this out there see if anyone had any ideas.

It's an 05 GT auto with 54k miles.

I'm thinking tune , catalytic converters , maybe trans issues who knows...

---------- Post added at 07:23 AM ---------- Previous post was at 07:21 AM ----------

Btw idk if this is relegated but its still havering MAJOR starting in the cold issues...
 

·
Registered
Joined
·
3,783 Posts
Sounds like it needs tuned up. Or the tune itself has went haywire. With the starting issue, I'm leaning towards tune up.
 

·
Registered
Joined
·
1,405 Posts
Discussion Starter #3
tc x 4 said:
Sounds like it needs tuned up. Or the tune itself has went haywire. With the starting issue, I'm leaning towards tune up.
Like new spark plugs n stuff? My dealership offered a "tune up" for cars around 60k miles for around $300-$400
 

·
Registered
Joined
·
3,783 Posts
Jgill1992 said:
Like new spark plugs n stuff? My dealership offered a "tune up" for cars around 60k miles for around $300-$400
That's a good price at the dealer.

---------- Post added at 09:00 AM ---------- Previous post was at 08:56 AM ----------

Make sure they can't ream you if they break the plugs off tho. If they do and can, it'll get really expensive really fast .
 

·
Registered
Joined
·
309 Posts
It sounds weird, but I would check the alt first. Seems like that goes bad around 50k, it goes slowly, and it causes all kinds of strange problems. If its not that, I'd look at plugs, coils, fuel filter, and then fuel pump. Its odd you didn't get a CEL with how sensitive these things are.
 

·
Premium Member
Joined
·
6,120 Posts
BenGT07 said:
It sounds weird, but I would check the alt first. Seems like that goes bad around 50k, it goes slowly, and it causes all kinds of strange problems. If its not that, I'd look at plugs, coils, fuel filter, and then fuel pump. Its odd you didn't get a CEL with how sensitive these things are.
+1!
 

·
Registered
Joined
·
1,405 Posts
Discussion Starter #7
BenGT07 said:
It sounds weird, but I would check the alt first. Seems like that goes bad around 50k, it goes slowly, and it causes all kinds of strange problems. If its not that, I'd look at plugs, coils, fuel filter, and then fuel pump. Its odd you didn't get a CEL with how sensitive these things are.
New fuel pump. But yea no CEL at all. I'm sure it needs plugs/coils and a new alt wouldn't hurt but can theese things really cause power loss this bad?
 

·
Registered
Joined
·
984 Posts
Jgill1992 said:
Like new spark plugs n stuff? My dealership offered a "tune up" for cars around 60k miles for around $300-$400
What does the tune up consist of? New plugs an what else ? I'm at 58k mines a 05 GT automatic will need a tune up soon
 

·
Registered
Joined
·
1,405 Posts
Discussion Starter #9
Terminator said:
What does the tune up consist of? New plugs an what else ? I'm at 58k mines a 05 GT automatic will need a tune up soon
I (think) they told me new plugs, oil change coolent flush some sort of transmission service? (Maybe fluid flush?) and new belts and such for the engine. Brake pads ect.. It was probably a year ago when they told me about it ill probably call and verify this weekend
 

·
Registered
Joined
·
309 Posts
Jgill1992 said:
New fuel pump. But yea no CEL at all. I'm sure it needs plugs/coils and a new alt wouldn't hurt but can theese things really cause power loss this bad?
The Alt could def cause power loss. When the coils go out on an auto, usually you'll notice an occasional catch, it'll feel like the tranny is having problems. The plugs going... Probably not, but because of how sensitive these cars are, they act weird sometimes.

If the fuel filter is the original, def should do a new one of those.
 

·
Registered
Joined
·
1,405 Posts
Discussion Starter #11
BenGT07 said:
The Alt could def cause power loss. When the coils go out on an auto, usually you'll notice an occasional catch, it'll feel like the tranny is having problems. The plugs going... Probably not, but because of how sensitive these cars are, they act weird sometimes.

If the fuel filter is the original, def should do a new one of those.
It's got a new fuel filter (2k miles)

That seriously sounds like my issues.. It does act weird and almost feels like it misses everyone in a wile. I should just order new plugs , coils And an alt. lol
 

·
Premium Member
Joined
·
6,120 Posts
Jgill1992 said:
It's got a new fuel filter (2k miles)

That seriously sounds like my issues.. It does act weird and almost feels like it misses everyone in a wile. I should just order new plugs , coils And an alt. lol
Well you can test the alternator with a volt-meter that would be the simplest way to go. Coils and plugs are well known to have issues on the 4.6L
 

·
Registered
Joined
·
309 Posts
Jgill1992 said:
It's got a new fuel filter (2k miles)

That seriously sounds like my issues.. It does act weird and almost feels like it misses everyone in a wile. I should just order new plugs , coils And an alt. lol
If I were you I'd just get the alt tested before you throw all that money at it. The coils are expensive. Like a hundred bucks and change apiece. Should do plugs though.
 

·
Registered
Joined
·
1,405 Posts
Discussion Starter #14
BenGT07 said:
If I were you I'd just get the alt tested before you throw all that money at it. The coils are expensive. Like a hundred bucks and change apiece. Should do plugs though.
Alright ill take it by the dealer tomorrow and have them test it. I'm really hoping to get my power back. Still faster than a camaro tho ;D
 

·
Registered
Joined
·
915 Posts
Alternator would of been my first choice as well, mine has done that
 

·
Registered
Joined
·
3,783 Posts
Jgill1992 said:
Alright ill take it by the dealer tomorrow and have them test it. I'm really hoping to get my power back. Still faster than a camaro tho ;D
Orielys test for free.
 

·
Registered
Joined
·
1,987 Posts
"having a fine car that is slow is like having a hot girlfriend that won't put out"!

Get an UGLY girlfriend, They ALWAYS put out and if she leaves you, You can ALWAYS find another ugly one and you won't be Heartbroken.
 

·
Registered
Joined
·
3,783 Posts
NewMtang said:
"having a fine car that is slow is like having a hot girlfriend that won't put out"!

Get an UGLY girlfriend, They ALWAYS put out and if she leaves you, You can ALWAYS find another ugly one and you won't be Heartbroken.
Your wise beyond your years. I prefer the cute fat ones myself, nothing like a prize winning show pig.
 

·
Registered
Joined
·
158 Posts
So far your list looks like this:
Coils
Plugs
Throttle position sensor
Dirty MAF
Fuel pump known issue with air in lines
Fuel filter
Alternator
 
1 - 20 of 38 Posts
Top