Mustang Evolution Forum banner

1 - 20 of 33 Posts

·
Premium Member
Joined
·
26,052 Posts
Discussion Starter #1
its 7:30 and they have been working on the rear end swap since around 6, i will be joining them soon to help them finish it up as soon as i get off work.

fun fun :good:
 

·
Premium Member
Joined
·
1,438 Posts
ahh rear end swaps arent hard they shouldnt have any problems... u guys got a lift?
 

·
Premium Member
Joined
·
26,052 Posts
Discussion Starter #5
HA no,... no lift be nice its an easy swap minus some of the issue that may come up with fitment, the swap its self is a cakewalk
 

·
Premium Member
Joined
·
1,438 Posts
what kinda car is it coming off of again?
 

·
Premium Member
Joined
·
1,438 Posts
evidentally not theyve been workin on it for 5 hours, when my bro dad and i did my bros camaro v6 to a z28 swap it only took around 3 hours im pretty sure
 

·
Premium Member
Joined
·
1,438 Posts
my bad his v6 maro rear to z28 rear lol
 

·
Premium Member
Joined
·
26,052 Posts
Discussion Starter #12
well its all over now the swap is in along with the speedcal unit. we ran into some snags... his ABS made it really hard to get the axles out, then the new rear end's lca slots were not wide enough so we had to widen then... i say that took a good 2 hours extra maybe more. Other than that it all went pretty smooth still dont knwo how it took so freaking long... oh well its all in.
 

·
Premium Member
Joined
·
3,216 Posts
Yup it is in, just dropped his old axles back off at his house and got home. Man what a day. Hes havin break troubles, hes gotta go all the way to the floor with it, so hes gonna have to take it to get looked at on monday I guess. We will post some pictures later, but hes prolly already in bed and I am tooo freekin tired to do so.
 

·
Banned
Joined
·
11,872 Posts
Yea I passed out as soon as I got home :lol:

Me and Nate got to Ben's house around 5:30 Yesterday and we rolled out of Ben's house at alittle after 3 last night :lol:

Yes my brakes were doing good for the first 5 min and then they just went soft. When I am slowing down the pedal goes all the way to the floor and it slowly comes to a stop. Do you think that the brakes need to be bleed more or what? I wouldnt think the front brakes would need to be since we didnt touch them but I dont know why its so soft.

Also I cant go over 73mph :lmao: and there is some kind of knocking noise when I get around 65-70. Dont have any idea what that is. It may be the speedcal cable hitting something I dunno.

Yea I really need my chip now lol. The SpeedCal corrected the Speedo almost perfectly it seems.

I'm to tired right now to go out and look it over I'll do that later. But once the main two problems are taking care of it will be soooo nice. :D
 

·
I liek gramer
Joined
·
8,537 Posts
too bad i couldnt be there.

I really missed getting home at 4 in the morning... :lmao:

Nah, I would have come, but my gf's little brother's birthday party was at the same time...
 

·
Banned
Joined
·
11,872 Posts
Well the brake issue is fixed.

The bolts that hold the brake line onto the caliper were lose and leaking when you hit the brake bad. I tightened those up on each side and took it for a spin and it was 100x better.

Now just got to get the chip in
 

·
Premium Member
Joined
·
1,461 Posts
Ya, those are called banjo bolts, they're VERY important as you found out. Glad to hear you got the rear installed, so now you need to make a post on that speed-cal, or else!!!
 

·
Banned
Joined
·
11,872 Posts
Well I am trying to figure out if my top speed is suppose to be 73 or if the speedcal has messed that up somehow.

I turn around 3000k rpms at 73mph.... def not the 4500rpms the rev lim is set at.... so I dont understand why it wont let me go over 73
 

·
Premium Member
Joined
·
1,461 Posts
What set of gears did you put in 4.10's right?
 
1 - 20 of 33 Posts
Top