Mustang Evolution Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
470 Posts
Discussion Starter · #1 ·
so my 96 gt is having issues with idle. it seems to idle high between like 8 and 900 rpms and if I rev it the rpms take FOREVER to go down to normal. of the car is rolling the rpms stay at like 1500 or so untill the car stops then after like 5 or 6 seconds of the car being at a stop the rpms will drop to normal. I tried unplugging the iac and the car actually runs better like the rpms go down at a normal speed when I rev it up then plug the iac back in and same thing again. could this mean my iac is bad? lmk guys and thanks
 

·
Registered
Joined
·
246 Posts
Sounds like you found the problem. You could try cleaning it first. I cleaned mine(same problem) it fixed it for a while then came back and I bought a new one and been good ever since(37K so far).
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #5 ·
I just switched my Dorman intake out for a ford racing pi and while I was at it I swapped my old iac from my oem throttle body on to my 78mm bbk and after doing all that when I start the car the rpms shoot up to 2000 rpms and won't go down. what could be my issue there?
 

·
Registered
Joined
·
1,069 Posts
Make sure the 2 hoses that go to the cold air intake are not backwards easy mistake


Sent from my 2003 rocketstang using Mustang Evolution


Sent from my LG-H918 using Mustang Evolution mobile app
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #7 ·
I dont think they are bc I think I left one of the hoses on while I did the job I will recheck though. any other suggestions? I'm at a loss here
 

·
Registered
Joined
·
1,069 Posts
Well that's what happened when I changed mine same exact thing

Sent from my LG-H918 using Mustang Evolution mobile app
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #9 ·
I'll definitely look at that when I get a chance whenever that is. I'll probably look at that then make sure my throttle cable is hooked up right maybe switch back to the other iac and check all my gaskets. idk what else it could be
 

·
Registered
Joined
·
1,069 Posts
It just sounds like you have the hoses backwards causing your rpms to be high took me a few to figure out I had them backwards easily fits either way so an easy mistake

Sent from my LG-H918 using Mustang Evolution mobile app
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #13 ·
I'm going to have time to check it out soon I'm going to look at that and make sure everything is hooked up and if not I'll switch the tunes on the intake
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #14 ·
ok so there was a tube I forgot to connect on the throttle body so that fixed that. now I'm having the same issues where the idle goes down really slow until I pull the iac valve clip. when I shut off the iac it goes down perfectly. I think I need a new iac valve untill i get one is it safe to drive around with it unplugged?
 

·
Registered
Joined
·
1,069 Posts
So you took care of the air leak good should be fine disconnected might die but shouldn't hurt anything besides maybe running like poop

Sent from my LG-H918 using Mustang Evolution mobile app
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #16 ·
it honestly runs a lot better with it unplugged. what is it that would cause the iac valve to do this? when you rev it the rpms go up but take a very long time to go back down and when the car is rolling there's no chance it will go lower then like 1500 then when you stop the car the rpms go down. if the iac is unplugged it doesn't do any of this
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #18 ·
ok I'll do that when I can it will probably be a few hours. but your saying if I had it unplugged for a week or 2 it won't damage anything
 

·
Registered
Joined
·
1,069 Posts
It shouldn't it just controls your idle

Sent from my LG-H918 using Mustang Evolution mobile app
 

·
Registered
Joined
·
1,069 Posts
Actually you car should idle very badly when disconnected the iac are you sure you don't have any vacuum leaks

Sent from my LG-H918 using Mustang Evolution mobile app
 
1 - 20 of 23 Posts
Top