Mustang Evolution Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Sudden? Gradual? Any other symptoms of info? Good be anything at this point. The more info the better.
Gradual. Been parked for more than a year now. It tirns on with some trouble but once warmed up it will stay on. Sounds good just that when i press on gas it studders and sometimes dies. I wanna go with a mechanic to check specifics from what i can get from help from here. Preciate ur help. When in drive it wont go. Tune up done with no improvements. What else could it b.
 

·
Banned
Joined
·
422 Posts
The tfi module on the distributor could cause that issue. I would test that first and go from there. There is a link in the stickies that shows you how to test it. Also when you did the tune up did you also replace the cap and rotor?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
The tfi module on the distributor could cause that issue. I would test that first and go from there. There is a link in the stickies that shows you how to test it. Also when you did the tune up did you also replace the cap and rotor?
Cap and roter was not replaced. I will though
 

·
Registered
Joined
·
84 Posts
I had a very similar problem when I rebuilt the top end on my 88. Started up and idled great. I got it out in the street and pushed the gas and it sputtered and barely went anywhere. Turns out my timing was was 180'd out even though I had marked my distributor. Check your timing.
 

·
Registered
Joined
·
39 Posts
I would definately check the timing. It sounds like its stumbling because of too much fuel. But that could be caused by the timing being out of whack an its not being burned properly. Good luck man
 
1 - 8 of 8 Posts
Top