Mustang Evolution Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter · #1 ·
This line connects here and goes towards the passenger side fender then disappears under the car. This hose is dryrotted and im pretty sure that it is the cause of my evap leak. Any idea what it is and where i can get a replacement?
 

Attachments

·
Lorraine's driver
Joined
·
8,214 Posts
I'm pretty sure that goes to the evap canister purge valve in the passenger side front fender. I don't know which one of these connections is it, but you should be able to tell after you remove the plastic fender well.

98564849.gif

Mine is getting crusty too. I'm not sure if there is a specific replacement part number for it. You might have to bring the tube in to an auto parts store to get a replacement of the right diameter and cut to fit the length. I'd definitely inspect the other hoses connected to this to make sure they aren't toast too, since you'll have it all exposed.
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #3 ·
I'm pretty sure that goes to the evap canister purge valve in the passenger side front fender. I don't know which one of these connections is it, but you should be able to tell after you remove the plastic fender well.

View attachment 205994

Mine is getting crusty too. I'm not sure if there is a specific replacement part number for it. You might have to bring the tube in to an auto parts store to get a replacement of the right diameter and cut to fit the length. I'd definitely inspect the other hoses connected to this to make sure they aren't toast too, since you'll have it all exposed.
Already replaced the extremely dry rotted hose and reset the code and it came back... i was told that i should now try replacing the purge valve

Sent from my SM-G900V using Mustang Evolution mobile app
 
1 - 3 of 3 Posts
Top