Mustang Evolution Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
984 Posts
Discussion Starter · #1 ·
Okay so my stang won't stay on thought It would of been the alt. so I swapped it out last night car cranks on just 2 min later it fights to stay on an just dies and if I put it into gear it quickly dies an jerks it's an auto by the way not sure what else it could be :(
 

·
Registered
Joined
·
1,890 Posts
Can you read any CEL codes?
 

·
Registered
Joined
·
359 Posts
I changed my alternator after similar issues and found it to be the battery after the fact. The battery just sucked even though it tested 'good' according to the load tester.
 

·
Registered
Joined
·
984 Posts
Discussion Starter · #9 ·
So it wasn't the battery it turns on just fine but than 4 secs later turns off I feel like it could be a sensor
 

·
Registered
Joined
·
1,890 Posts
IT's strange that you don't get any CEL light or codes. Maybe the battery has a bad cell. Can you start it and have someone pull the battery cable immediately?
 

·
Registered
Joined
·
68 Posts
Okay so my stang won't stay on thought It would of been the alt. so I swapped it out last night car cranks on just 2 min later it fights to stay on an just dies and if I put it into gear it quickly dies an jerks it's an auto by the way not sure what else it could be :(
Same thing is happening to my 93
 

·
Registered
Joined
·
1,563 Posts
It sounds like the fuel pump to me? Have you had the fuel pressure checked coming into the fuel rail?
 
1 - 20 of 30 Posts
Top