Mustang Evolution Forum banner

1 - 20 of 63 Posts

·
Registered
Joined
·
185 Posts
the 05 is an electrical nightmare.... alternators going south with low milage, Batteries exploding, door locks, dash clusters failing at will, gas tanks not filling back up properly, window acuation problems as well, shaker systems have also been known to fry.... sure im leaving a few out but its not just me in this boat
 

·
Registered
Joined
·
254 Posts
Yea after I bought my 06 gt the alternator went out not even a month of having it then the transmission failed on me had to have that replaced to I had nothing but problems with it so I traded it for my 2010 now
 

·
Registered
Joined
·
185 Posts
I know mine and alot of people are having problems with syncronizers too
I have to say, my manual trans has always been unusually noisy from day one and with only 50k on it. I know its the "NEW" Tremic 3650 model so I have kinda just shrugged it off thinking its the nature of the beast but who knows. All I do know it this is my 5th mustang and none of them did I ever think the trans was ever noisy toll this. tell layla to roll down hear to cocoa beach, I'll even let her drive it too so no one thinks im crazy lol
 

·
Registered
Joined
·
34 Posts
bryanbrock said:
I have to say, my manual trans has always been unusually noisy from day one and with only 50k on it. I know its the "NEW" Tremic 3650 model so I have kinda just shrugged it off thinking its the nature of the beast but who knows. All I do know it this is my 5th mustang and none of them did I ever think the trans was ever noisy toll this. tell layla to roll down hear to cocoa beach, I'll even let her drive it too so no one thinks im crazy lol
I hear ya, mine is noisy off and on, but i know mine hates trying to shift at high rpms
 

·
Registered
Joined
·
19 Posts
My wife has an 05 V6 and I drive an 09 GT. Her cluster gauge started going bad. At first it was the temp gauge. I never saw a temp gauge go in a total 360 circle until I saw hers. Ford replaced it for $800 since it was out of warrenty. You tube has some videos on pulling the whole unit and changing the motors out or you can pull it out yourself and send it off for repair for about $200. That includes changing out all the motors (Ford said they would all go eventually). I have read about it on this forum and others. Alot of folks want Ford to man up and recall but I doubt that will happen. It's one of those 1st new year problems.
 

·
Registered
Joined
·
185 Posts
My wife has an 05 V6 and I drive an 09 GT. Her cluster gauge started going bad. At first it was the temp gauge. I never saw a temp gauge go in a total 360 circle until I saw hers. Ford replaced it for $800 since it was out of warrenty. You tube has some videos on pulling the whole unit and changing the motors out or you can pull it out yourself and send it off for repair for about $200. That includes changing out all the motors (Ford said they would all go eventually). I have read about it on this forum and others. Alot of folks want Ford to man up and recall but I doubt that will happen. It's one of those 1st new year problems.
ok mr Bobby, WHO? does the refurb on an 05+ cluster for 200 dollars. We would all LOVE to know as many of us have been looking together to find someone who will.
 

·
Registered
Joined
·
565 Posts
I have owned two 2005 GT Manual mustangs and one 2007 Roush(gt) Mustang manual, and I had some odd problems on the one 05 with the windows but never had any dash issues or other electrical issues, or transmission issues with any of them. The clutch was extraordinarily stiff in the same 05, I traded it for the Roush. The GT's and the Roush have a combined mileage of about 130,000 miles. I've replaced the battery twice in the one 05, and once in the 07...
 

·
Premium Member
Joined
·
1,258 Posts
I keep hearing all of the problems with the alternator, but mine went for 189,872 miles before it went out on me. I really haven't had many problems at all with my car - at least not with the stuff that Ford did, the aftermarket stuff that I did I've had a couple of issues, but again nothing major.
 

·
Registered
Joined
·
19 Posts
OK Mr. bryanbrock, I thought my post would encourage a little research but it only encouraged doubt and sarcasm. I researched other forums and found several threads regarding the 2005 cluster problem. There's a similar thread, even on this forum, which addressed the same problem last month that even you, bryanbrock, chimed in about.
For those of you who have a cluster problem with your 2005 mustang or most GM products and don't want to fork over $800 to Ford, there are alternatives. Again, I can't speak for their honesty or integrity but one is
Mr Speedometer Inc
505 53 Avenue Southeast, Calgary, AB T2H 1K5, Canada
+1 403-258-2909 ‎
Their latest statement on their site was the following:
New! 2005 Mustang - Symptoms: Speedometer and other gauges not working. Repair Cost $169:
Also available on You Tube, if you are handy with a soldering gun, there's a do it yourself video. Good luck...I wish I had researched this before I paid Ford $800 to do the work. Do you need anything else Bryanbrock?
Thanks, Bobby
 

·
Registered
Joined
·
185 Posts
OK Mr. bryanbrock, I thought my post would encourage a little research but it only encouraged doubt and sarcasm. I researched other forums and found several threads regarding the 2005 cluster problem. There's a similar thread, even on this forum, which addressed the same problem last month that even you, bryanbrock, chimed in about.
For those of you who have a cluster problem with your 2005 mustang or most GM products and don't want to fork over $800 to Ford, there are alternatives. Again, I can't speak for their honesty or integrity but one is
Mr Speedometer Inc
505 53 Avenue Southeast, Calgary, AB T2H 1K5, Canada
+1 403-258-2909 ‎
Their latest statement on their site was the following:
New! 2005 Mustang - Symptoms: Speedometer and other gauges not working. Repair Cost $169:
Also available on You Tube, if you are handy with a soldering gun, there's a do it yourself video. Good luck...I wish I had researched this before I paid Ford $800 to do the work. Do you need anything else Bryanbrock?
Thanks, Bobby
No Bobby thats just fine, I will save the info and forward it to those who are dealing with this issue as is comes up again in the future. admittedly I did have little faith in your prior post, thank you for proving other wise:headbang:
 

·
Registered
Joined
·
459 Posts
I just got my car about a month ago from the dealer 06 GT mustang with 58,000 miles... I have a hard time fueling gas at the pump. First 3-4 gallons go in with no issues. After that the pump kicks back every sec . I tried pumping in an angle, try to control the flow of the gas by pulling in the trigger just a little but nothing works.
Took it back to the dealer and said that the 05 had a recall but the 06 models and up didn't. It's a normal thing... It's this true or they just gave me the run around... What to do...
 

·
Premium Member
Joined
·
6,120 Posts
I just got my car about a month ago from the dealer 06 GT mustang with 58,000 miles... I have a hard time fueling gas at the pump. First 3-4 gallons go in with no issues. After that the pump kicks back every sec . I tried pumping in an angle, try to control the flow of the gas by pulling in the trigger just a little but nothing works.
Took it back to the dealer and said that the 05 had a recall but the 06 models and up didn't. It's a normal thing... It's this true or they just gave me the run around... What to do...
I have that problem as well they should've recalled 05-09 Cars. It's really just annoying. Usually what I do is get as far as I can and then stop filling.

My issue is the Throttle Position Sensor going south.

Ford has a TSB but they will not honor it under their very own Ford ESP according to my dealer. My Service Advisor said, "well there is a TSB, but Ford wont cover it under their warranty until we flash the computer and you are liable for covering that cost." That was $270. So now I have to go buy the part install it and pay at-least another $100 to my Ford dealer to flash the computer again.
 

·
Registered
Joined
·
5 Posts
I had to replace my alternator around 40-50k, at least one battery, and a belt. Had problems w/the gas tank not filling up, something with the sensor thinkin it was full or something. Those were the only problems I've experienced, and got it in while it was under warranty for the gas tank issue. Never had electrical/transmission/noise issues whatsoever. 2005 GT I bought new in 05, around 79k miles so far!

---------- Post added at 12:25 PM ---------- Previous post was at 12:21 PM ----------

yea, I was told the whole gas tank was replaced, pretty sure they said it was a sensor issue thinking the tank was full? but that was 3-4 years ago so not totally sure. Just seemed for me it picked its times when it did/didn't do it. Of course it would do it when I was late and needed gas! def was annoying, but after getting it fixed I haven't had the issue. it was covered under my 35,000 warranty.
 

·
Registered
Joined
·
24 Posts
The problem I am having with my 06 GT is when I turn off the car my dash and interior lights will cycle on and off. When I open the door they will quit. Anyone know anything about this? Also my trans does seem to be noisy at times.
 

·
Registered
Joined
·
5 Posts
My Experience...

I have an 07 GT and a while after I got it I started noticing steamed up windows whenever it was warmer inside the car than outside. Turns out the thing had a half inch of standing water in the floorboards that was not noticable until I pulled up the carpet to access the fuse box behind the kick panel one day.

Found out it was a known problem with TSBs on it for all years 05 - 09. The problem can cause all sorts of electrical issues with almost every electrical system in the car because water can get into and corrode the fuse panel.

Took it to ford dealer for warranty repair who first said they found no sign of water (1/2 inch of standing water - very noticable). When I showed them the TSB they said a TSB was a "suggested service procedure" and does not mean its a problem with my car. Then when I pulled up the carpet and showed them the water, they stated "we don't get reinbursed enough by ford to do hard to diagnose repairs like this".

Well I insisted and they did some caulking at various places but did not even dry out the carpet and padding, much less replace it. No paperwork was ever issued on my "repair". The dealer said it would be mailed from ford and when I contacted ford they had no record of it.

Of course this is just one of many issues with the 05 to 09 Mustang that has had TSBs issued on it. In order for a recall to be issued for a problem they must have a very large number of documented cases of a problem and they must pose a safety threat.

Many problems are "cured" by aftermarket parts that a lot of people install, many problems are intermittant and are ignored or the problems never get noticed because of infrequent usage.

My guess is most people just put up with "their" problems until they eventually decide to unload their Mustang onto someone else who has no idea of the issues they are buying into - that is the nature of this type of car. I would not expect any recalls.

One last note: a new 6 gauge cluster for 05 - 09 installed by a dealer should be around $500 parts and labor.
 

·
Registered
Joined
·
111 Posts
I have water that come down from under my glove box an soaks my floor. Took it to ford and the said i had a leak from my glasstop and water gets in. It hadn't rained for months b4i took it to them. They "tryed" charge me $1000 for "diagnostics" they didn't do on it. But the TBS never got wet but what is the reason it just leaking water outta nowhere?

---------- Post added at 12:32 AM ---------- Previous post was at 12:31 AM ----------

TSB*
 
1 - 20 of 63 Posts
Top