Mustang Evolution Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
So I just did a "Pi" swap & the car is running GREAT powerwise but the check engine light comes on & says I have a "random miss". It has new motorcraft plugs & new pep boys brand wires & about 3 month old "scream'n deamon" coils from summit. The car seems to shake a lot around 1000 rpm. Any ideas what this could be? Could it be because I haunt got it tuned yet?
 

·
Registered
Joined
·
153 Posts
96 stang said:
So I just did a "Pi" swap & the car is running GREAT powerwise but the check engine light comes on & says I have a "random miss". It has new motorcraft plugs & new pep boys brand wires & about 3 month old "scream'n deamon" coils from summit. The car seems to shake a lot around 1000 rpm. Any ideas what this could be? Could it be because I haunt got it tuned yet?
It is probably because it isn't tuned. Also are you still using the npi brain. If so I can almost guarantee that's what it was. I'm about to do this myself. Any good suggestions or tips would be great.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #5
Yea I am using the stock computer. The only problem I had was with the dipstick (kind of a tight fit) & make sure the holes on the back of the "Pi" heads are plugged! I made a huge mess of oil on the floor because I didn't know about them. I also used this copper spray on head gaskets & exhaust manifold gaskets to help with heat transfer. I can post a pic later. Another issue I had was the line that runs under the intake didn't fit because the intake is deeper so we custom fab'd a line that runs to the heater core.
 

·
Registered
Joined
·
153 Posts
96 stang said:
Yea I am using the stock computer. The only problem I had was with the dipstick (kind of a tight fit) & make sure the holes on the back of the "Pi" heads are plugged! I made a huge mess of oil on the floor because I didn't know about them. I also used this copper spray on head gaskets & exhaust manifold gaskets to help with heat transfer. I can post a pic later. Another issue I had was the line that runs under the intake didn't fit because the intake is deeper so we custom fab'd a line that runs to the heater core.
That would be great. Can't wait to get mine done. :D
 
1 - 7 of 7 Posts
Top