Mustang Evolution Forum banner

1 - 20 of 51 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hi guys! Brand new to the forum! Recently purchased a mustang from my dealership in September and have put about 2k miles on it since then. I had them clean the throttle body as well as clean my battery's ground cable (Corrosion) in hopes to fix this rhythmic vibration to no avail. Cleaning my ground cable fixed my unsteady voltage and keeps it between 13.7V-14.2V. I watch my RPMS flutter between 700 and 550 and just before it feels like it will stall, my cooling fan kicks on and the rough idle continues. Then goes away after the vehicle has warmed up and no shop can replicate it :banghead::banghead: But when she's all warm she loves the abuse I put on her, so should I try to keep determining the source of the harsh idle and rpm fluctuation or say screw it and just build it till a rod comes through my hood?

Aside from the point, looking to put these mods in and make 350 out of the V6 at least, can anyone give me any pointers on any of these mods? Looking to do it over Winter so she can be bada** for Spring

-Xtreme Stop Precision Cross-Drilled & Slotted Brake Rotor & Carbon Graphite Pad Kit - Front & Rear
-Borla Stinger S-Type Cat-Back Exhaust w/ Polished Tips
Ford Performance Cut and Clamp X-Pipe
-BBK 1-5/8 in. Ceramic Tuned Length Shorty Headers
-Roush Cold Air Intake
-Airaid PowerAid Throttle Body Spacer
-Bama X4/SF4 Power Flash Tuner w/ 2 Custom Tunes (91 Race and 91 Street)
-BBK 73mm Throttle Body
-SR Performance Aluminum One Piece Driveshaft
 

·
Registered
Joined
·
1,158 Posts
You 'might' have found out why the last owner got rid of the Mustang you bought :(. Might be something simple or something major wrong with the motor :(. I would fix what's wrong before modifying it. Don't waste any money on a throttle body spacer, they do nothing for fuel injected motors. You won't make 350 horsepower (flywheel) with the mods you are going to do :( Maybe 330-340 at the most :( I guess you also have the 2.73 (for gas mileage) rear gear ratio? There is a little white tag on the back of the pumpkin cover with the ratio printed on it. Good luck on your quest for more power :)
 

·
Registered
Joined
·
1,259 Posts
4 Power adders on the list, the best being the Shorties that is good for Low to Mid level HP and Torque which is what the 3.7 needs for real world driving, then the tuner running premium and then it is a toss up between the throttle body and the X-pipe.
Unless you are going for the looks of the CAI, look at the Airraid MIT (Modular Intake Tube). The Mustang already has a CAI on it and I have the Airraid on mine that is the same as the Roush, I would have put the MIT on mine if it was out when I bought the CAI.
Brakes I don't know about those you are looking at, but I have a set of Drilled and Slotted that came off my truck that were Name Brand Garbage.
My V6 has the same as Factory Brembos on it :cool:
Oh and the abuse, I live really close to the Tail of The Dragon.
So does David but he never wants to go up there with me :whistling:
 

Attachments

·
Registered
Joined
·
1,158 Posts
Carol won't let me :(. Too many people been killed there :(.
 

·
Registered
Joined
·
1,259 Posts
I don't hurt the Mustang up there, but a rock did attack me on 25w the other day and broke my bumper

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
Hey David! Sorry for the late reply. I've been fiddling around with it some more. Mine has the 3.73 gears in the rear, I'm beginning to wonder if it could be my alternator and possibly the MAF sensor being dirty :shrug: The car had actually sat for a while before he traded it in. My curiosity leads me to think the MAF could be causing the rough idle, it hasn't done it as bad now that it's getting freezing in PA :eek: and as for making the RPM flutter it seems to be electronically related. Any power drain causes it's RPM to jump around (I rarely ever use the AC or heat) I've noticed if my windows are up and I try to roll them up again I'll see my RPM drop to as low as 500-550. Holding my high beams on at idle as well will drain it down that low and make the car feel like it's about to stall out. Tried explaining it to a service tech and he wasn't able to give me a concrete answer because "they can't replicate it" or "its normal" :banghead: I am thinking of taking it to another Ford dealership just to see if they can find out, but I've never heard anything really spectacular about their service in my area :( Do any of your V6's do this? I mean even when my cars warmed up my rpm gauge never sits right at 750 it's always bouncing around dipping into the 650's

I agree with the premium tune, and I should save up for brembos :cool: Maybe 350 was being unrealistic without doing MAJOR work to it. I'm just looking to make her a little quicker and more responsive. I appreciate your guys' responses dearly and forgive any ignorance I may have, I'm just getting into the community :)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
Also found out after a lot of heavy rain this past few days she (2014 V6 Premium Package) likes to store water in the driver side quarter panel/wheel well area :) :) :) (Thankfully no interior carpeting or leather is getting wet or damp) but you can hear it under hard braking or cornering.
Tech's told me it was my gas tank but it did it with 10 miles to empty or 200 miles to empty. Didn't matter. But I found parking my car at a decline instead of an incline let the water drain out. As well as I found little clips in the bottom lip of the doors. I opened both and watched about half a cups worth of water come draining out of the one closest to where your feet would be. "It's the gas in your tank sloshing around" mmhm. sure. I mean other than that Idle issue, she run like a dream as is. I've gotten her up to 120 and have been lighting up the tires around some of the sharper turns my area has. My heart wants to say screw it and just start putting things in her, but the better part of me knows that I need to get what issues she's having checked out, but no one ever gives me a steady answer :(

---------- Post added at 08:42 AM ---------- Previous post was at 08:42 AM ----------

Also found out after a lot of heavy rain this past few days she (2014 V6 Premium Package) likes to store water in the driver side quarter panel/wheel well area :) :) :) (Thankfully no interior carpeting or leather is getting wet or damp) but you can hear it under hard braking or cornering.
Tech's told me it was my gas tank but it did it with 10 miles to empty or 200 miles to empty. Didn't matter. But I found parking my car at a decline instead of an incline let the water drain out. As well as I found little clips in the bottom lip of the doors. I opened both and watched about half a cups worth of water come draining out of the one closest to where your feet would be. "It's the gas in your tank sloshing around" mmhm. sure. I mean other than that Idle issue, she run like a dream as is. I've gotten her up to 120 and have been lighting up the tires around some of the sharper turns my area has. My heart wants to say screw it and just start putting things in her, but the better part of me knows that I need to get what issues she's having checked out, but no one ever gives me a steady answer :(
 

·
Registered
Joined
·
59 Posts
With 3.73 gears you'll want to avoid blasts to 120mph. Your stock driveshaft might explode at that speed with those gears. With stock 2.73's, the limit was 135mph safely. With 3.73's that limit is much lower than 135mph.
 

·
Super Moderator
Joined
·
17,800 Posts
350 out of the V6? You shoulda bought the 5.0 tbth... You'll need to supercharge or turbocharge it to hit that number.
 

·
Registered
Joined
·
1,158 Posts
If your speedometer is correct, the last owner left a tune installed when he sold it or traded it in on something else. He or she might have had long tube headers and CAI. maybe a few other bolt on parts but removed them. Might be the reason for some of your problems. I'll check to see if the windows affect my idle later today.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #11
18 and V8's hahaha, my insurance hated me when I thought about getting one. I'm talking $800+ a month just to insure! I definitely thought about it, but couldn't swing the insurance payment on top of the car payment lol
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
Hey Dave, yeah do that and see if you notice anything. Everything in my track apps has the regular A/F ratio, Temps are on point, so I'm freaking stumped! In all honesty I wondered if the car had actually had any work done to it that was taken off :facepalm: I tried calling the guy that traded it in cause I found him in our sales portal, but never answered a call or voicemail. I'm beginning to wonder if he did work because a lot of the interior kick-paneling around the footwell area is actually missing (I'll upload a picture when I go on my lunch)

If you lay on the floor of either the driver side or passenger side you can see right up into ALL the electronics under the dash. Which sincerely leads me to wonder if the guy had actually done a tune and some work that he decided to take off before he traded it to get into another car without reflashing to the stock tune.

I wonder if doing a factory reset by pulling the battery could reset the computer back to factory settings:confused: There's definitely some stuff that went on with this thing that I want to get to the bottom of hahaha.

I only did the one run up to that speed. I stopped looking at the dash after it crossed 110 as it was on highways, but I could still peripherally see it still climbing. So she still feels healthy and runs well. I'm taking any suggestions on things to do to remedy the situation :banghead: You guys will be able to tell me if this is regular or not, wait until I upload the picture of the underside of the dash in a few hours
 

·
Registered
Joined
·
1,158 Posts
I just did the headlights and windows check. My idle never changed any at all. Pulling the battery will reset the adaptive learning of the automatic transmission and maybe a few other things but it won't install or reset the factory tuning. When its gone its gone. You would probably have to go to a Ford dealer and pay them to reinstall the factory settings to the PCM. I'm no expert and might be wrong on some of the things I'm telling you :)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #14
That's really odd! So it's definitely something unique to my vehicle. I guess I'm gonna have to bring it into the Ford shop to see what they say. I've found a bunch of things that I can really nit-pick over but biggest concern to me is engine health, transmission health as well as the health of the electronics. From my research looking into this it seems these 3 could be the biggest factors in a rough idle

It appears the power drain is what makes it seem like it's about to stall so my assumptions about the alternator may be true, or the battery may be bad. There's so many things that can cause this the more I look into it! :mad: I'm getting ready to take my lunch in about an hour or so, I'll upload the pics into this chat as soon as I get a chance to. I just hope that now with the newfound confidence yours doesn't do that, I'm going to my "not so well rated" local Ford to explain to them the issues I've had. Here's hoping the rumors I've heard were just that, rumors :nonono::eek:

Will make sure to post about everything they tell me. Thank you so much for checking that simple thing for me David. Hell, I'll take a video of it tonight so that way you guys can see and I have extra ammo in my arsenal for when I go to my local Ford Dealer

I just did the headlights and windows check. My idle never changed any at all. Pulling the battery will reset the adaptive learning of the automatic transmission and maybe a few other things but it won't install or reset the factory tuning. When its gone its gone. You would probably have to go to a Ford dealer and pay them to reinstall the factory settings to the PCM. I'm no expert and might be wrong on some of the things I'm telling you :)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #15
I've also heard that after installing headers it can cause a surge in the idle or unsteadiness, a lot of the symptoms I'm describing fall in line with that and it leads me to believe that it seems like someone put some headers on, then took them off and never reflashed the computer back to factory settings
 

·
Registered
Joined
·
154 Posts
Try the idle relearn. Turn the car to accessory and let the dash settle,
then slowly push the gas pedal to the floor,
hold for a second or two then slowly release the pedal,
turn the car off
then start the car

If I missed a step or said something wrong someone please correct me.

You might need a new throttle body, which isn’t hard to change or at least clean it.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #17
I may have to try that and see if it works. Thank you! :D I'm trying to save money to be able to bring it into a shop. Going to upload the pictures of the inside now to show where I think someone was doing some tinkering

Try the idle relearn. Turn the car to accessory and let the dash settle,
then slowly push the gas pedal to the floor,
hold for a second or two then slowly release the pedal,
turn the car off
then start the car

If I missed a step or said something wrong someone please correct me.

You might need a new throttle body, which isn’t hard to change or at least clean it.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #18
Well here she is boys, this is the interior of Lucy. Whenever I first had bought the car I hadn't noticed any of this until my girlfriend had pointed out that the interior paneling in the passenger footwell was actually not firmly connected and secured. So I began piecing it together only to realize that both sides are missing the top most portion of the kick panel and all the guts of the dash are easily visible. Looks like electric tape got used on a few wires as well. Keep in mind my dumba** didn't notice this WHEN I BOUGHT IT :banghead: Take a look at some of this guys. :(:whistling: The first two are of the passenger footwell looking straight down then looking up into it. The following are of the driver side footwell and you can clearly see the steering column as well as the ambient lighting and some other electronics. Does anything appear tobe messed with? Aside from the obvious fact I'm missing my kick panels :lol:
If you lay on the floor of either the driver side or passenger side you can see right up into ALL the electronics under the dash. Which sincerely leads me to wonder if the guy had actually done a tune and some work that he decided to take off before he traded it to get into another car without reflashing to the stock tune.
 

Attachments

·
Registered
Joined
·
154 Posts
My driver side looks like that as well. I haven’t looked at the passenger side. I’ll check when I get back home and let you know.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #20
Okay I'm glad that at least is normal. It almost looks like the passenger one was torn out if you look at the edge of it on the upper leftmost side.

Much appreciated TCU, I'm going to try the relearn process whenever I get off work. Sales and a Saturday means I don't get to leave the office to go screw with her even though it's cold and no one's buying cars when it's about to snow hahaha. Give me some time and I'll get back to you if that did anything, good or bad
My driver side looks like that as well. I haven’t looked at the passenger side. I’ll check when I get back home and let you know.
 
1 - 20 of 51 Posts
Top