Mustang Evolution Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have a 2014 mustang v6, this morning I went to start my car and it the car started bogging our pretty bad almost wanted To die. First time this has happened, it was really cold outside and rained overnight and I have 20 miles till empty. Could it just be the weather messing with it? Never had this problem.

Also my radio had been making a pop sound then turning off until I shut the car off and started it back up. Now it’s completely out besides the time flashing and the cd will say loading and make the noise continuously. I’ve read a lot about that but never found a solution. Any suggestions to either problem? Thanks!
 

·
Registered
Joined
·
411 Posts
If you did not get any trouble codes and the problem does not reoccur I would not worry about the bogging. Wet and cold is not going to make any engine happy. You could try pulling the radio fuse or disconnect your battery for a while to see if your radio resets. Other than that there is really nothing you can do but bring it to a dealer or buy a new unit.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
that’s good to hear I was assuming the cold wet weather is why since that it hasn’t really happened like it did this morning starting it up later in the day, for the radio I disconnected the battery for 30 minutes pulled the fuse still nothing. Ford just wants money to look at it probably to tell me it needs to be replaced. Any suggestions for a new unit?
 
1 - 3 of 3 Posts
Top