Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
1992 mustang 5.0

So pretty much my car ran perfectly fine. i bought the car a cam, fuel injectors, fuel reg, mass airflow, new intake manifold, throttle body, cold air intake. Car drove perfectly fine no problems. Then the car started struggling when you gave it gas almost like it didnt want to run while it back fired and had no power. While in neutral no problem idle was great. Gave it gas no problem. Put the car in first gear started driving car would start back firing and shaking. Got to the stop sign car rpms would go up and down then after 10 seconds car would turn off. I would go to turn the car on the car wouldn't turn on. If i hit the gas then turned the key the car would turn on. No idle problems. Drive little bit and the problem would start all over. Unless i was at the light in neutral giving the car a little gas. Was too scared to drive the car so i would just take it home. I changed the throttle position sensor, indle control and the baf sensor. Now that i changed the spark plugs and cables. The car is not drivable. Put it in first gear i could slam on the gas and the car just turns off
 

·
Registered
Joined
·
493 Posts
You can rent a tool from autozone, or LMS sells a gauge that screws into the schrader valve for like $40. That's what I have, and it beats renting a tool everytime!
 

·
Registered
Joined
·
493 Posts
91notchback said:
You can rent a tool from autozone, or LMS sells a gauge that screws into the schrader valve for like $40. That's what I have, and it beats renting a tool everytime!
LRS that is...lmao!
 

·
Registered
Joined
·
493 Posts
38-40 psi with vac line on fuel pressure regulator removed and plugged with something. I'm curious as hell as to what's causin your issues man.
 
1 - 12 of 12 Posts
Top