Mustang Evolution Forum banner

1 - 20 of 25 Posts

·
Banned
Joined
·
11,872 Posts
Discussion Starter #1
My freaking blinker when turned on goes freaking nuts. It blinks at 90mph. Is this normal!!! My last car didnt do this (95 V6)........... btw I have a 96 V6 now.... :confused:
 

·
You want to **** me?
Joined
·
4,043 Posts
usually when it does this the side that it blinks real fast, the light is about to burn out. Is it just one side or both?
 

·
Registered
Joined
·
798 Posts
Ponycarman said:
you got a bulb out. I got a 96 and it blinks noramlly, until a bulb goes out then it acts hyper.

Steve
I agree....:spot:
 

·
Registered
Joined
·
386 Posts
Its perfectly normal for the 1996 models to do this.
Ford wanted to upgrade them. So they installed the Ford Motorsport Hyper Blinkers. Its to make your car look cooler and better. It also makes your car look like its faster.



lol, "is this normal" ur funny. bulb out my friend.
 

·
Registered
Joined
·
1,552 Posts
Bulb out on both sides? Turn blinker on, get out and check to see if there is a burned out bulb, check front and rear, then turn on the other side, check same.
 

·
Registered
Joined
·
1,552 Posts

·
Registered
Joined
·
798 Posts
was video'ing the stereo necessary? had my volume up and it scared the **** out of me when the vid started. :)
 

·
Registered
Joined
·
1,715 Posts
Ive seen some of the imports around here with signals that do that, id willing to bet that someone swaped out the flashers.
 

·
Premium Member
Joined
·
908 Posts
ok 2 things

When my blinker was doing that I asked someone about it and they said it might be something like the timer in it is off or some crap. Found out tho it was definitely the burnt out light so there ya go.

second thing.. your car is possesed by a large pigtailed girl zombie o_O
 

·
Banned
Joined
·
11,872 Posts
Discussion Starter #16
Seph said:
ok 2 things

When my blinker was doing that I asked someone about it and they said it might be something like the timer in it is off or some crap. Found out tho it was definitely the burnt out light so there ya go.

second thing.. your car is possesed by a large pigtailed girl zombie o_O
pigtailed girl zombie....?
 

·
Registered
Joined
·
22 Posts
My ex-girlfriend had this problem in her paseo, but we never fixed it. I would think that it is a resistor somewhere in the line, but who knows. Also, on your alpine, see if you can put it on autoscroll, unless you don't want that. On mine, forget what model, but has blue buttons, you have to select autoscroll for it to continue scrolling.
 
1 - 20 of 25 Posts
Top