Mustang Evolution Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
i have an automatic 1967 mustang that will start but it wont go. when i change it into any gear it wont go. it doesn't move on parking which its obius. but when i put it in drive, reverse, or any other gear it wont go only if you push it but it will feel like in neutral. none of the changing gear's wires that make it change gears are broken or ripped. so what is wrong.
 

·
Registered
Joined
·
46 Posts
Most automatic transmissions from the '60s were pretty straightforward. If the fluid level and condition are good and the shift linkage is still working right, there isn't much outside the transmission to go wrong. The kickdown linkage only affects upshifting and downshifting.
 

·
Registered
Joined
·
45 Posts
transmission fluid full ? the servo may be stuck(internal part).if it is a standard then you have a clutch problem.
 

·
Registered
Joined
·
44 Posts
The scroungerssrantt working and lacking of pressure makes it impossible to shift. you need to rebuild that puppy,
 

·
Registered
Joined
·
39 Posts
Sounds like low transmission fluid level. Have you checked your transmission fluid? Any automatic transmission vehicle won't move if it doesn't have the right amount transmission fluid. If it turns out there's plenty of fluid then it could be the shifter is off set or the transmission is bad. Good Luck
 

·
Registered
Joined
·
38 Posts
I had the same problem, this past monday my transmission blew, and my car wouldn't move either, it wouldn't let me change to park or drive from reverse...it would start though.
 

·
Registered
Joined
·
30 Posts
Come on ,you say 1967 Mustang.
Oh God 52 years old.Model

You should get the transmission oil checked or even top up if required.If the transmission is fine.

Congratulating you and Wishing you good luck for keeping such an car in operative condition.
 
1 - 10 of 10 Posts
Top