Mustang Evolution Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
i have a 1999 ford mustang and today i went to start my car and it just clicks and i also realized that my negative terminal is smoking. i tried cleaning the terminals and it still didnt start. I also checked the battery and it is fully charged. thx in advance to any answers
 

·
Registered
Joined
·
33 Posts
I don't think you did a good enough job cleaning the inside of the battery connectors and the battery terminals. Smoke from heat is due to a bad connection and you can't "see" bad electrical connections most of the time. Likewise the battery should be recharged and "load tested" to make sure it's good at the auto store. Use the wire brush below for easy battery terminal maintenance.
PS Like Carl says below, it's always possible you have a big short circuit on the starter motor connection to the battery.

http://www.jcwhitney.com/autoparts/Search?catalogId=10101&storeId=10101&sku=battery+brush
 

·
Registered
Joined
·
44 Posts
Sounds like a loose battery connection. That is if the battery is indeed, fully charged. Did you check it with a voltmeter or did you take it to a place that sells batteries so they could do a proper load check on it. Most of the time you can have a plumb dead battery and a voltmeter will still read 12v.
 

·
Registered
Joined
·
25 Posts
If you are sure the battery is fully charged, and the starter just clicks, then it would be a bad connection or loose at the negative terminal. Take it off, clean it, and put back tightly.
 

·
Registered
Joined
·
41 Posts
If you don't have a good connection the high amperage tries to pass through a small contact area producing heat. Also. if you have a bad starter, it can cause extremely high amperage and heat the cables.
 

·
Registered
Joined
·
40 Posts
I could be the starter solenoid is bad and if you keep trying to start it the battery cables will get hot the mustangs are known for the solenoids going bad. hope this helps
 
1 - 9 of 9 Posts
Top