Mustang Evolution Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a 2013 V6 with BBK LongTube Headers and off-road X-pipe and Borla Atak cat-back. After a long time, and numerous trips to the shop I figured out my engine light was a bad O2 sensor. I bought two front NTK sensors from American Muscle and they have great reviews. My performance shop said NO use Ford ones, Well they are A LOT more. Anybody have experience with Ford verses NTK?? Also If I just stick with Ford like I have, I have been told to replace both, and that it doesn't matter. I am very confused and need some advice! What do you guys think?
 

·
Premium Member
Joined
·
5,321 Posts
Your check engine light is from not having cats because of your x pipe...

Sent from my VS985 4G using Mustang Evolution mobile app
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
P2251. I've confirmed its the O2 sensor with some trouble shooting and a multi meter. I just don't know which ones to use
 

·
Premium Member
Joined
·
5,321 Posts
The ones you have are fine. Follow up question- are you using o2 extensions?

Sent from my VS985 4G using Mustang Evolution mobile app
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Yes I replaced them and same code. I switched only the O2 sensor to the other side and the new code came up on the other side. That's how I know if that helps.
 

·
Premium Member
Joined
·
5,321 Posts
You would have to ask a cyclone owner but usually there are retaining clips holding up the wire and with that gone it typically gives you enough room to connect them.

Sent from my VS985 4G using Mustang Evolution mobile app
 

·
Registered
Joined
·
8,578 Posts
I prefer to use OEM parts for things like sensors. But since you already bought a replacement, just go ahead and use it. Even the OEM sensors fail.

I don't think that it will be a problem using one aftermarket, and one OEM.
 
1 - 11 of 11 Posts
Top