Mustang Evolution Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Okay this is my first 4.6 I was a little leary but I got a deal I couldn't pass up. When I got the car the CEL was on and it had a lil bit of a miss.
Forgot to mention 99 gt 5 spd. Offroad h pipe no cats short throw shifter. That's all I can spot aftermarket.
The CEL is a p0453 code which is evap emission system pressure sensor/switch high input.
So when I'm cruisin around it missfires/studders at about 1/4 to 1/3 throttle. WOT it runs great. When I get or on the highway acceleration is not a problem. Cruising at 65-70 is pretty easy. But if I start going up a long hill and don't downshift to get the rpm's up my miss returns.
So I wanted to to start cheap replaced the plugs today and found that I have two replacement coils. It ran GREAT no hesitation at all. I drove to my dads visited for about an hour, got back in the car and everything was back to runnin kinda poopy lol.
Only now she spits and spudders throughout a bigger gap in the throttle movement. WOT still rips and tears but I can't drive thru town with out it sounding like I'm drivin a beat on pinto!
Can that evap code be the culprit? Or should I replace the coils?
Or should I look somewhere else?
I'm lost guys, please help me!

Also,
The coils didn't look the greatest and the plugs that came out where rusty. I picked up autolite platinum and gapped them at 54.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Cool, just making sure. I searched and searched and couldn't find the same thing I'm dealing with. I'm really liking this new 4.6. Besides the missing it has alot of potential.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Yeah I thought the gap sounded kinda big to me but that's what the book calls for. And from what I can find, people have been doin that and it's workin for them?? I'm outa town for work right now but when I get home I'm goin back to the parts store to check for misfire codes. And I'm gonna check the valley like you said. I'm gonna put the conclusion on here cause it seems like alot of others have this same problem. Thanks for the reply I really appreciate it.
 

·
Registered
Joined
·
24 Posts
The 4.6 has a small vacuum elbow at the back of the intake on passenger side that alot of time it will rot and cause similar symptoms its part of the PCV system just a thought. How does it idle?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Sometimes it idles good sometimes it's up and down. i never put to much thought into it. Now that you mention it I'll pay closer attention.
 
1 - 8 of 8 Posts
Top