Mustang Evolution Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter #1
Hey guys, so im driving home the other day, and I happen to look down at my dash and see that the temp light is on, and the needle is maxed out past the Red on the thermostat. Luckly I was within walking distance from home and I left the car were I stopped it to cool down. Later I went back to bring it home, but checked the oil and coolant and all were fine! I kept it running and drove it around the area a few times and nothing. Just normal.

Any Ideas?
 

·
Registered
Joined
·
271 Posts
Discussion Starter #6
that is a good guess and worth trying. Was it in traffic? That would make me want to see if the fan is kicking on but at speeds it often isn't used.
It was in town traffic, lot of stopping from red lights. Going to check the cooling fan resistor while im at it. I think that perhaps what could have contributed to it was my setting the rpm to 1200 at driving idle. But I had it like that for two weeks and nothing. Just in case, I set it back down to 800.
 

·
Registered
Joined
·
544 Posts
Yeah setting the idle rpm's higher may have contributed to the heat factor but I am not 100% positive on that especially since it looks like you are in New York.

None the less thats a good idea to change it to a lower value to see if it was the problem.
 

·
Registered
Joined
·
7 Posts
I had the same problem with my car about a month ago. It started to overheat and the coolant leaked out everywhere. I changed the thermostat and I drove it for a week with no problems. But one day while downtown the temps got really high so I pulled over and shut it off and just a couple drops of coolant came out. I checked all the relays and fuses and they were fine. I narrowed it down to the low speed fan resistor as the fan would go on high but not low. I ordered the part from Ford but it was on back order so I went to a local auto parts store and picked up a whole new fan, shroud and resistor and installed it. No problems at all after that. I even was driving all day today downtown in stop and go traffic and the car was fine, temps were perfect. Hope this helps!


Sent from my iPhone using Mustang Evolution
 
1 - 9 of 9 Posts
Top