Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Getting this code on my '00 v6. Changed the cam sensor (no change). Heard alternator! Can i just swap my alternator for my '02 gt just to try it out.

Sent from my SM-N910V using Mustang Evolution mobile app
 

·
Registered
Joined
·
342 Posts
P0340 is for the cam position sensor. If swapping the sensor didn't fix it I would be looking at the wiring between the sensor and ECU.
 

·
Registered
Joined
·
3,274 Posts
Change the cam position sensor. If that doesn't work the issue is likely the alternator. The wiring harness on these cars allows a bad diode in the alternator to screw up all sorts of things.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
Got it started. unplugged the alternator runs a lot better so I'm guessing thats what it is.ty

Sent from my SM-N910V using Mustang Evolution mobile app
 

·
Registered
Joined
·
55 Posts
Discussion Starter #6
Update. Finally got around to changing the alternator. Still get the same code! Won't stay idleing. Should I try the sensor again?
 

·
Registered
Joined
·
8,556 Posts
Einstein says that the definition of "insane" is doing the same thing over and over again, and expecting a different result.

So no. One new camshaft sensor is probably enough for right now.
You need to start looking into the wiring circuit for the camshaft sensor. Verify that there is continuity, and that there is no damage to the wiring.
 

·
Registered
Joined
·
70 Posts
If the cam sensor, wiring and pcm are good it could be a issue with the timing. The chain could have jumped a tooth. A cam / crank sensor correlation test can be done with a lab scope. Or the timing could be checked the old fashion way by taking the chain covers off and seeing if the trimming is correct. No work has been done to it recently ? This is push rod engine with a small chain that usually don't have the issues which is more common in overhead cam engines. Another thing is some after market sensors have issues. Is it a own part? Just because a part is new doesn't mean something is not wrong with it.

Sent from my SM-J327P using Mustang Evolution mobile app

---------- Post added at 03:47 AM ---------- Previous post was at 03:47 AM ----------

Is it a oem part*

Sent from my SM-J327P using Mustang Evolution mobile app
 
1 - 11 of 11 Posts
Top