Mustang Evolution Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
:oops: i had a transmission place install my superior shift kit for AOD-E tran. well i leave my car there with the shift kit, 5 quarts of mecron V, and a new filter...
5 hours later he calls me and says its ready but need to bring 3 more quarts of fluid... i get there dump 2 quarts in and me and him take it for a drive.... out of the parking lot and on the road first gear sounds awesome then chirp it hits 2nd and im loving it then 3rd.... then a stop sign i stop then when i start to go it will not go into gear just rpms climb.... so he says turn around lets put that other quart in.... dump that in and he says go try it again.... take it down the road and kickin ass again get up to 60ish and rpms keep climbing will not go into OD i press the button on my shifter and the OD Off light comes on and the car sounds ok again.... wtf is up? i told the guy to fix it and that i think the OD band is not lined up cuz i had already read wetdonkey's post and saw the picture here is link http://www.3.8mustang.com/forum/showthread.php?t=49577 ... he told me that he would have to take it apart and try that and to pick it up tomorrow.... my question is.... was i right in assuming the od band is off and what else could the problem be? and what is the max amount of fluid this bastard tranny can hold?
:oops:
 

·
Registered
Joined
·
1,895 Posts
how much fluid is this guy putting in?

the aode tranny requires like 12.5 quarts.
According to the haynes manual.

sounds like you only put in 9 qts.
Other than that, i know nothing about auto tranny's.

Monkey knows alot about them, iam sure he'll help u.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
you guys rock i will put more fluid i guess tomorrow ill ask the guy if he removed the converter cuz if he didnt then i shouldnt need the max amount of fluid cuz most should have stayed in right?
 

·
Registered
Joined
·
1,895 Posts
You never know, call him and ask what he did.
He may of drained the tranny to install everything.
You gave him 5 qts, then he asked for 3 more, sounds like he may of drained it and didnt know exactly how much to put in.

Hows the dipstick, is the fluid level where it should be when the cars running?
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
i dunno he was doin all the checkin i left the car there so he could try and see if the od band was not aligned right in the morning sposed to pick it up around 11 am ill call him and ask him to check the fluid lvl and ask him if he drained converter...is there any other thing that could be wrong? my car has 59k miles on it and was serviced month ago and had absolutely no problems shifting or anything before i got this kit installed....
 

·
Registered
Joined
·
1,895 Posts
again, i feel bad, but this is where my "automatic" knowlege ends.
Tomorow morning you'll have more replys. I know more about the t-5.
Mattsdrag95 would seriously beable to help you. But he's never on.
:(
 

·
Registered
Joined
·
39 Posts
Discussion Starter #8
all is well now man, i was right bout the servo band not being aligned and the fact that the fluid hadnt been put in like ppl recommend it took little time for it to run right but its great now and i love it
 
1 - 8 of 8 Posts
Top