Mustang Evolution Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
So, i have begain to take notice that my car has a noticable rattle comming from within the transmission area. I replaced the clutch when i got the car along with the fork and pivot ball. The throw out bearing or pilot isnt the issue, im certain.
It happens more frequently if im in rpm ranges of 2500 to just under 3500 (could be more the exaust is louder at 3500rpms) and suppose i start in 2nd from a start... Its really noticeable too. Its not a tap or knock... Its for sure a rattle. But oddly enough... It comes and goes. Transmission shops can never seem to hear it and i know its an issue. I was thinking input shaft bearing but, I think id ask my Mustang family hear for any related issues or such. Please help! my cobra isnt a rattle snake!!
 

·
Registered
Joined
·
2,472 Posts
ToplessCobra said:
So, i have begain to take notice that my car has a noticable rattle comming from within the transmission area. I replaced the clutch when i got the car along with the fork and pivot ball. The throw out bearing or pilot isnt the issue, im certain.
It happens more frequently if im in rpm ranges of 2500 to just under 3500 (could be more the exaust is louder at 3500rpms) and suppose i start in 2nd from a start... Its really noticeable too. Its not a tap or knock... Its for sure a rattle. But oddly enough... It comes and goes. Transmission shops can never seem to hear it and i know its an issue. I was thinking input shaft bearing but, I think id ask my Mustang family hear for any related issues or such. Please help! my cobra isnt a rattle snake!!
Idk how to help. I'm just sayin that's a clever title
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #4 ·
Idk how to help. I'm just sayin that's a clever title
I hoped the title would attract interest. Lol

---------- Post added at 11:02 PM ---------- Previous post was at 11:01 PM ----------

úp cho ngày cuối tuần nào :D
Wait... What!??

---------- Post added at 11:03 PM ---------- Previous post was at 11:02 PM ----------

My 96 gt does the same thing and has for about a year... I've never found what's causing it
Really? Is it a common t45 issue maybe?
 
1 - 7 of 7 Posts
Top