Mustang Evolution Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
317 Posts
Discussion Starter #1
Im getting a clunk sometimes in the right rear of my cobra when i take off from a dead stop. Its a pretty loud pop. Thought at first it was the tranny mounts but its in the rear for sure. Anyone else have this issue? Maybe a rear control arm bushing or just hitting the bump stop?
 

·
Registered
Joined
·
185 Posts
sounds like its time for a new rear end. I did the exact same thing on my 98 GT showing off for a hot chick. clukned intermitently all the way back home some times little sometimes violently. Had to go get a new one from the junk yard it costed me 700 and took about 2 and a half hrs to swap out.
 

·
Moderator Emeritus
Joined
·
4,786 Posts
Brad.krieg said:
Im getting a clunk sometimes in the right rear of my cobra when i take off from a dead stop. Its a pretty loud pop. Thought at first it was the tranny mounts but its in the rear for sure. Anyone else have this issue? Maybe a rear control arm bushing or just hitting the bump stop?
Likely a control arm bushing has collapsed, or it's possible that the rear sway bar has broken. The sway bar on my 1st 95 snapped off at the control arm on the passenger side, was hard to tell on the ground by looking. Had to grab it or put it on the lift.
 

·
Registered
Joined
·
317 Posts
Discussion Starter #4
bryanbrock said:
sounds like its time for a new rear end. I did the exact same thing on my 98 GT showing off for a hot chick. clukned intermitently all the way back home some times little sometimes violently. Had to go get a new one from the junk yard it costed me 700 and took about 2 and a half hrs to swap out.
Hmm well, i just rebuilt the rear end. My mechanic lives and breathes mustangs. Shouldnt b that. Usually that sound would be a whine.
 
1 - 4 of 4 Posts
Top