Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
560 Posts
Discussion Starter · #1 ·
Just recently I'll start my car and it'll rev up like normal and just die. I'll start it and it'll do it about 2 more times but always on the third time it stays running. What's the reason why it's doing this? Any help?
 

·
Registered
Joined
·
558 Posts
How quickly does it die when you start it the first 2 times???? I would think it had to be something with the fuel system or maybe your computer.. And does it do it after you have driven it around and then tried to start it again, or just when it's cold??
 

·
Registered
Joined
·
560 Posts
Discussion Starter · #5 ·
How quickly does it die when you start it the first 2 times???? I would think it had to be something with the fuel system or maybe your computer.. And does it do it after you have driven it around and then tried to start it again, or just when it's cold??
It'll just start up and rev up like its gonna stay started then immediately die. It's only starting happening lately when it's super cold out. It's done it one time while driving so my power steering when out and my brakes locked up. I'm glad there were no cars around.
 

·
Registered
Joined
·
540 Posts
I bet it is the iac. The idle air control. Crank car and press gas to keep rpm at 900. When u let off and it dies its the iac module. Looks like a c cell battery with one plug on top of it and 2 bolts on the throttle body.
 

·
Registered
Joined
·
560 Posts
Discussion Starter · #9 ·
I bet it is the iac. The idle air control. Crank car and press gas to keep rpm at 900. When u let off and it dies its the iac module. Looks like a c cell battery with one plug on top of it and 2 bolts on the throttle body.
After I rev it up it'll stay on but it I just start it when pushing in the clutch and without any gas it'll start up like normal then just die.
 

·
Registered
Joined
·
540 Posts
Sounds like the iac to me. Google iac for your year mustang for a pic. It's super easy to replace. Two bolts and one plug.
 

·
Registered
Joined
·
319 Posts
+1 on the iac. Try cleaning it real good with carb cleaner before buying one. I had a 98 that did the same. Sprayed the crap out of the iac and it ran fine afterwards.
 
1 - 11 of 11 Posts
Top