Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #1
I just bought the aeroforce interceptor gauges for my 2012 v6 I have a mild tune from mpt paired with a streeda cai. When I go to the page to see my a/f ratio, ideling I run around 14 which is about right. When I accelerate heavily I read about a 12. When I let off the gas, the number shoots up to a 28. If I tap the gas it goes back to running at normal. Is this just an error in the computer or is the car actually running that lean? Didn't think it was possible...

Sent from my XT1080 using Mustang Evolution mobile app
 

·
Registered
Joined
·
4,516 Posts
With mine (manual) when I'm on the gas normally it's around 14, but if I let off, most of the time it shoots up to 20, but never more, until I get in the gas again then back to 14ish. This is with Bama. I've only run Bama in this car and while they might not be the most aggressive tuner out there, I have never had any issues with their tunes.
Shooting up to 28 might concern me, but only because Ive never seen mine do it before.

Sent from LG G3.
 

·
Registered
Joined
·
473 Posts
At idle mine is around 13.8-14.2
Need to see what it's at while accelerating


2011 3.7 mustang

---------- Post added at 09:35 PM ---------- Previous post was at 09:34 PM ----------

And I have bama v2


2011 3.7 mustang
 

·
Registered
Joined
·
128 Posts
Discussion Starter #4
Mine is also a manual. I've been running the same tune since last year

Sent from my XT1080 using Mustang Evolution mobile app
 

·
Registered
Joined
·
128 Posts
Discussion Starter #5
Should I be really worried? Is this a big enough issue that I shouldn't even be driving the car?

Sent from my XT1080 using Mustang Evolution mobile app
 

·
Registered
Joined
·
119 Posts
I have the same gauge and the same numbers at full deceleration around 28:1 AFR. I'm auto. Pretty sure it's normal as your at full vacuum. As you Slow down still off throttle it starts to normalize. When you get really on the throttle like WOT does either 02 sensor drop to 00.00 for a couple seconds? One of mine does. At wot I'm at 11.5-12.5
 

·
Registered
Joined
·
128 Posts
Discussion Starter #7 (Edited)
Same here. It never goes higher than 28. During wod its around 11. But I'm sure I do not have them set up right because its saying that i have two different oil temperatures that are above 1200 degrees?

Sent from my XT1080 using Mustang Evolution mobile app
 

·
Registered
Joined
·
119 Posts
Make sure your set up on number 4 that's Ford Mustang info. Also some things won't show or calculate right since that gauge also works on many other cars and our OBD2 port only supplies Ford Mustang data. Not turbo.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #9
Is there a online manual for the aeroforces? Most of the options they have on them I have no clue what they mean. I bought them used off a forum member

Sent from my XT1080 using Mustang Evolution mobile app
 

·
Registered
Joined
·
1,314 Posts
Mine shoots up to 20.0 when I lay off the gas while driving as well and I'm all stock under the hood. If I were you I would only worry about the ratio while using the throttle. If you have the digital readout keep your eye on the cylinder temp... if that's not running high you should be fine. Lean will cause your engine to run hot so as long as your temp is fine and no codes are throwing, I personally wouldn't sweat it.
 

·
Registered
Joined
·
3,710 Posts
Fuel injectors turn off when you get off the gas before it goes back to the idle fueling values. This is 100% normal and nothing to worry about.
 

·
Registered
Joined
·
2,093 Posts
MPT is one of the best 3.7/3.5 email tuners out there (for Mustangs and EcoBoost trucks). You're fine.
 
1 - 12 of 12 Posts
Top