Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
I found when i push gas pedal the engine is not react quickly...
What would be the problem??
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Actually i bought this car as used one.. So i dont know when it started.
But on the high speed they respond more quick...
 

·
Registered
Joined
·
323 Posts
Im willing to bet you've got Carbon buildup. You need to either clean your fuel system yourself, or take it to a decent shop and have them do it. Be sure you do it right- some parts may have to come off and be cleaned by hand. But don't let anyone talk you into idiot fixes like pouring water into the carb. , or driving it out. Just google 'carbon buildup' and you'll find what you need.
 

·
Registered
Joined
·
121 Posts
This "lag" is an emissons related program point in our cars, it's done to keep emission spikes out of the equation when apruptly changing trottle position. It can be removed by a tuner. Everybody I know with the factory programming complains about it..........
 

·
Moderator Emeritus
Joined
·
4,786 Posts
05bluestang said:
This "lag" is an emissons related program point in our cars, it's done to keep emission spikes out of the equation when apruptly changing trottle position. It can be removed by a tuner. Everybody I know with the factory programming complains about it..........
+1 this correct. In each of my three programs in my chip the throttle response is progressively better as the tunes get more aggressive. Even on the stick type tune it is better then no tune I know this as fact because I drove mine for a month with out the chip, and this is an issue with any Mustang not just the newer ones.
 
1 - 12 of 12 Posts
Top