Mustang Evolution Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Yo Testicleez... did you ever find out what was up with your clutch? Mines gettin worse, and im gettin ready to take it somewhere to get looked at.
 

·
Registered
Joined
·
13 Posts
Danger Dude said:
That really sounds like the pressure plate not evenly engaging


Corey
Sorry I didn't update you guys on this. About a month ago I had the shop tear it down again. They said everything was fine. No uneven wear, no runout on the flywheel, nothin.

Bad news, it still did it. Joshness is not the only one I've talked to that's had this problem, funny thing is is that its only been with the centerforce stage 1 kit.

When I installed the pedal height adjuster from MM I had to tighten down the adjustable cable (non firewall adjuster) to take up the slack and have proper disengagement/engagement, this seemed to help, but every once in a while it will still shudder. I've just grown to accept, its just annoying because it causes my cai to hit my strut tower.

I think the lesson learned here is that the c/f stage 1 kit sucks. I don't think I'll be buying from them again.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
I was very close to taking my car in this weekend and getting a rental car to have them do a tear down to look at mine as well. Sounds like its a good thing that I didnt. How many others do you know of that are having the problem?
 

·
Banned
Joined
·
7 Posts
i have my OEM (ca. 1998) clutch and i notice the same thing, but only when reversing from a dead stop up my inclined driveway at around 1000rpm. if i disengage the clutch and go up above 1500 rpm the shuddering stops. i have 77k miles on the vehicle.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
I broke down and brought my car in, because the shaking was getting so bad I thought the tranny was gonna fall out.

Its in the shop right now, and they told me that the Pressure Plate on the Centerforce was bascially dissolved. The wire ring that has the centrifigual weights on it (centerforce only) was all screwed, and the 1/2 weights came off. Hence the shuddering. THey also said the plastic CLutch Quadrant/Adjuster was broken, so the ford "Auto adjusting Clutch" wasnt working anymore either.

The good news, the clutch was still under the 90 warranty - so free parts. The Quadrant is also being replaced with a Billit FRPP piece, so that will be fixed too.

The bad news, labor, plus the extra part needed will still cost me about a toal of 450 bucks.

Stay away from Centerforce, and everyone should replace thier Stock PLASTIC Quadrant with an alluminum one (~$100 for the kit).

"Ford, where quality is job one." <-- MY ASS!!
 

·
Premium Member
Joined
·
26,052 Posts
you need to buy a quadrent adn adjuster and put just enough tention on it so that it does not slip when driving. just a tad bit of pressure on the cable all the time. i would buy a new cable and a quadrent with an adjuster and try that out. My friends nissan with a spec cltuch does the same thing its terrible....i figured it was cuz he didnt have enough tq and the pressure plate clamped down on it hard and he didnt have the car moving fast enough to over come this issue.

to shake there would have to be something wrong with the pressure plate, flywheel, or the springs on the clutch disk, which are there for that exact reason to aborb the tq energy to keep the car from shaking....

also the input shaft could be moving a bit or something odd like that....

i would contact centerforce and get a new pressure plate from then adn disk....if you can that is.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #7
Uhh, did you even read my last post.

Its basically trhe same thing you just explained. The pressure plate was screwed up, and the quadrant broke. Both of them are geting repaired/replaced.
 

·
Registered
Joined
·
58 Posts
CLUTCH = RIP

ok, about 5 minutes after i pulled out of my friends house my clutch starts shuddering while going into 2nd. So i pull off and try to adjust it. Nothing. Then, i start out of 1st and its squeeling and clanking and popping like a mofo. Same with 2nd gear. Then, i shift to third and its still hard to press, but it doesnt ake noise. So i took it to the shop. Anyone have a prob like this? BTW, there was white smoke under the hood when i stopped, and it...

"SMEELEED LIKE BUURNING!!!!"
 

·
Registered
Joined
·
29 Posts
Discussion Starter #9
Sil/erSpeed,

Aftermerket or stock clutch? How many miles on the car?

If you have the original stock clutch, it might just be going out. If you get it replaced, DONT BUY CENTERFORCE - centerforce is a good comapny, dont get me wrong, but they cant seem to make V6 Stang clutches worth a damn
 

·
Registered
Joined
·
13 Posts
[No message]
 
1 - 10 of 10 Posts
Top