Mustang Evolution Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
470 Posts
Discussion Starter · #1 ·
Last night i put my intake filter back on after cleaning it and also cleaned to throttle body the idle was a bit rough so i let it warm up and took it around for a little check engine light came on i graded my code read and it said it was a misfire... I turned the car on the code was gone drove around for a little code didn't come back on but its still idling rough and when I'm at a light it stays at like 1500 and takes a while to come down.
Any idea what it could be? Thanks
 

·
Registered
Joined
·
2,208 Posts
Last night i put my intake filter back on after cleaning it and also cleaned to throttle body the idle was a bit rough so i let it warm up and took it around for a little check engine light came on i graded my code read and it said it was a misfire... I turned the car on the code was gone drove around for a little code didn't come back on but its still idling rough and when I'm at a light it stays at like 1500 and takes a while to come down.
Any idea what it could be? Thanks
Clean your mass air flow sensor
 

·
Registered
Joined
·
2,101 Posts
Clean your mass air flow sensor
+1..probably over oiled your filter, first start up sucked all the excessive oil on the filter and stuck to the MAF..they sell MAF cleaner made by CRC
 

·
Registered
Joined
·
470 Posts
Discussion Starter · #4 ·
I thought i did myself lmao! I already got the MAF clearer cause i was knocking out all the easy fixes and was up to MAF if it don't work any other suggestions ?
 
1 - 7 of 7 Posts
Top