Mustang Evolution Forum banner

1 - 20 of 52 Posts

·
Registered
Joined
·
776 Posts
Discussion Starter #1
Well its been about 3 weeks now and ive noticed my car has been driving a bit rough. Smells like gas upon start up and has been getting AWFUL gas milage 15.4MPG average. I recently replaced fuel filter, spark plugs, and wires as well as a oil change. I'm getting concerned that something is wrong. I also am running a bama street tune...... also i am currently on winter tires. Mod's are in my signature as well....... someone please help! If this helps i have about 52k miles 01 V6....... i drove it last week really lightly mostly city driving and got 15.9MPG :/
 

·
Lorraine's driver
Joined
·
8,197 Posts
Well its been about 3 weeks now and ive noticed my car has been driving a bit rough. Smells like gas upon start up and has been getting AWFUL gas milage 15.4MPG average. I recently replaced fuel filter, spark plugs, and wires as well as a oil change. I'm getting concerned that something is wrong. I also am running a bama street tune...... also i am currently on winter tires. Mod's are in my signature as well....... someone please help! If this helps i have about 52k miles 01 V6....... i drove it last week really lightly mostly city driving and got 15.9MPG :/
Maybe your tune is running a little too rich..? That would explain the smell and the bad gas mileage. Maybe try switching back to the stock just long enough to tell if your probs go away. If they do, call up Bama and let them know and they'll adjust your tune. :good:
 

·
Registered
Joined
·
776 Posts
Discussion Starter #3
Azure said:
Maybe your tune is running a little too rich..? That would explain the smell and the bad gas mileage. Maybe try switching back to the stock just long enough to tell if your probs go away. If they do, call up Bama and let them know and they'll adjust your tune. :good:
See thats what I was thinking...... can i use one of the strategy tunes to help fix my speedo for the 4.10's? I dont really know how to tune on my own.
 

·
Lorraine's driver
Joined
·
8,197 Posts
See thats what I was thinking...... can i use one of the strategy tunes to help fix my speedo for the 4.10's? I dont really know how to tune on my own.
I think you could, but I'm not sure what the stragedy tune base is. It could be too agressive, maybe. You could certainly try that, altering only the gear adjustment and run with it for a time. If you still have the symtoms, then you could try the stock tune, knowing your speedo will be off during that time.
 

·
Registered
Joined
·
776 Posts
Discussion Starter #5
Azure said:
I think you could, but I'm not sure what the stragedy tune base is. It could be too agressive, maybe. You could certainly try that, altering only the gear adjustment and run with it for a time. If you still have the symtoms, then you could try the stock tune, knowing your speedo will be off during that time.
Wount that rack up extra miles???
 

·
Lorraine's driver
Joined
·
8,197 Posts
Wount that rack up extra miles???
Don't do Seafoam yet. Determine if your problem is the tune first.

With the stock tune...You'll only run it long enough to determine if the tune is your problem. You should know pretty quick as you'll stop smelling the gas. If the gas smell goes away with the stock tune, then call Bama and tell them what you did and they'll adjust your tune.

If your concerned about the miles and your in-accurate speedo, flash the Bama tune back on while you wait to hear from Bama.
 

·
Registered
Joined
·
7,311 Posts
Sounds like a clogged cat to me if its not the tune...after driving the car for a bit at night look under the car... if one if your cats is glowing you know its clogged
 

·
Registered
Joined
·
776 Posts
Discussion Starter #9
Thanks for all the pointers, thing is I only smell gas when its a cold start, another weird thing i noticed is that when im crusing around 2k ish with out the car shifting or me pushing on the gas or taking it off, the rpm's drop like 200ish then come back up..... and you can feel it.... idk thats not normal
 

·
AmericanMuscle.com
Joined
·
2,878 Posts
Well its been about 3 weeks now and ive noticed my car has been driving a bit rough. Smells like gas upon start up and has been getting AWFUL gas milage 15.4MPG average. I recently replaced fuel filter, spark plugs, and wires as well as a oil change. I'm getting concerned that something is wrong. I also am running a bama street tune...... also i am currently on winter tires. Mod's are in my signature as well....... someone please help! If this helps i have about 52k miles 01 V6....... i drove it last week really lightly mostly city driving and got 15.9MPG :/
I'm sorry to hear about the issue your experiencing. This sounds pretty odd considering you just did a lot of maintenance. It sounds like we need to look in your tune!

Give the Bama team a call and they'll make any necessary revisions and point you in the right direction! Our Bama Performance tuning specialists are here in the building Monday-Friday from 9AM-5:30PM EST and Saturday 9AM-5:30PM EST. You can hit them up directly at 888.226.9764.

-Dan
 

·
Lorraine's driver
Joined
·
8,197 Posts
Thanks for all the pointers, thing is I only smell gas when its a cold start, another weird thing i noticed is that when im crusing around 2k ish with out the car shifting or me pushing on the gas or taking it off, the rpm's drop like 200ish then come back up..... and you can feel it.... idk thats not normal
For the RPM fluctuations, do the idle re-learn and that should help. Slowsix, the V6's have the idle re-learn, correct?

  1. Disconnected NEG from battery for 30 minutes.
  2. Reconnected battery and started car letting in idle while the engine gets to temperature, then wait one minute.
  3. Turn the AC to Max a little over one minute, then turn off.
  4. Then go drive the car for about 10 miles.
 

·
Registered
Joined
·
1,996 Posts
It could be a long shot but I've seen it before. Does your car feel like it's not pulling as hard as normal? I ask because what it makes me think of is a clogged cat. If you don't have any luck with the tunes etc. I would maybe look into the cats being your issue. Only other reasons I could see for your problem is a fuel/spark issue.
 

·
Registered
Joined
·
776 Posts
Discussion Starter #13
AMDanBailer said:
I'm sorry to hear about the issue your experiencing. This sounds pretty odd considering you just did a lot of maintenance. It sounds like we need to look in your tune!

Give the Bama team a call and they'll make any necessary revisions and point you in the right direction! Our Bama Performance tuning specialists are here in the building Monday-Friday from 9AM-5:30PM EST and Saturday 9AM-5:30PM EST. You can hit them up directly at 888.226.9764.

-Dan
Thanks Dan! My cars been doing this awhile, with a couple different tunes from you guys

---------- Post added at 05:21 PM ---------- Previous post was at 05:20 PM ----------

Azure said:
For the RPM fluctuations, do the idle re-learn and that should help. Slowsix, the V6's have the idle re-learn, correct?


[*]Disconnected NEG from battery for 30 minutes.

[*]Reconnected battery and started car letting in idle while the engine gets to temperature, then wait one minute.

[*]Turn the AC to Max a little over one minute, then turn off.

[*]Then go drive the car for about 10 miles.
Im going to give that a shot!

---------- Post added at 05:23 PM ---------- Previous post was at 05:21 PM ----------

DaBluedude said:
It could be a long shot but I've seen it before. Does your car feel like it's not pulling as hard as normal? I ask because what it makes me think of is a clogged cat. If you don't have any luck with the tunes etc. I would maybe look into the cats being your issue. Only other reasons I could see for your problem is a fuel/spark issue.
Idk, i have a custom exaust and only two cats..... no clue what brand or if stock cats, when i start my car up tomorrow morning ill see if smoke comes out evenly from both sides
 

·
Registered
Joined
·
776 Posts
Discussion Starter #14
Ok i just did the relearn and she feels better to drive. Ill update when i get to the gas station in the next few days
 

·
Registered
Joined
·
776 Posts
Discussion Starter #15
Alright I need everyone's help again, filled up yesterday, 15.58 Mpg the cats don't glow after a long ride. Idk what could be wrong. Any ideas? I talked to a friend today and she said since its colder our cars get worse mpg? That true? It's still like in the 30s here and my car is parked inside most nights. I'm lost guys!
 

·
Registered
Joined
·
3,274 Posts
Alright I need everyone's help again, filled up yesterday, 15.58 Mpg the cats don't glow after a long ride. Idk what could be wrong. Any ideas? I talked to a friend today and she said since its colder our cars get worse mpg? That true? It's still like in the 30s here and my car is parked inside most nights. I'm lost guys!
Colder is better for power and fuel economy. What kills mpgs in cold weather is people letting their car idle forever so that its nice and toasty inside. If your cats had been glowing at somepoint, you really need to get it on a lift and have the cats checked and probably replaced. Bad cats will murder fuel economy.

Is there a cel?
 

·
Lorraine's driver
Joined
·
8,197 Posts
Alright I need everyone's help again, filled up yesterday, 15.58 Mpg the cats don't glow after a long ride. Idk what could be wrong. Any ideas? I talked to a friend today and she said since its colder our cars get worse mpg? That true? It's still like in the 30s here and my car is parked inside most nights. I'm lost guys!
I'm seeing about a 2 MPG drop since winter hit. I hear that it is normal to see a drop in MPG, but not sure how much. I also let my car warm up, so it idles for several minutes on the really cold days.
 

·
Registered
Joined
·
776 Posts
Discussion Starter #18
See I hardly let my car idle when it's cold out. I brought up the glowing cats cuz I was told to check that. I figured cold weather the better my car would run. It seems like my rpms like to drop suddenly and come backup this only happens when accelerating.
 

·
Lorraine's driver
Joined
·
8,197 Posts
See I hardly let my car idle when it's cold out. I brought up the glowing cats cuz I was told to check that. I figured cold weather the better my car would run. It seems like my rpms like to drop suddenly and come backup this only happens when accelerating.
It should because the air is colder and more dense. This also means it will require more fuel as well. How much lower of MPG are you getting?
 

·
Registered
Joined
·
3,274 Posts
Check your spark plugs. Also, when is the last time you changed your fuel filter? Do you have any trouble codes?

Letting the vehicle idle will cost you some mpg. But also, during winter, gas station switch to a different blend of fuel, which isnt as great as what you would get in the warmer monthes.

Your problem doesnt sound like cold, or fuel blend. If your not throwing an engine code, it could be your fuel filter or spark plugs. Especially if your only getting issues with acceleration. Those are good places to start. Check that and get back to us.
 
1 - 20 of 52 Posts
Top