Mustang Evolution Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
Ok yet another post. I've looked and completed all the repairs I've found on here for the following issue
Hard to start. Turns over fine. Take 2 or 3 times to actually start. Repair replaced fuel pump and filter, problem not as bad .

Car exhaust has a horrible odor emissions smell. Timing is set at 10 deg. Replaced o2 sensors.

Last. Car sounds like it has a very healthy cam (not sure if it does it came that way) noticed at times it varies. Cleaned maf. Will be making sure today that the tps is at .95 vdc


The reason I posted all at once is due to I have done the individual issue. Diagnosis. Wondering if the all did in somewhere.
 

·
Banned
Joined
·
8,779 Posts
Ok yet another post. I've looked and completed all the repairs I've found on here for the following issue
Hard to start. Turns over fine. Take 2 or 3 times to actually start. Repair replaced fuel pump and filter, problem not as bad .

Car exhaust has a horrible odor emissions smell. Timing is set at 10 deg. Replaced o2 sensors.

Last. Car sounds like it has a very healthy cam (not sure if it does it came that way) noticed at times it varies. Cleaned maf. Will be making sure today that the tps is at .95 vdc

The reason I posted all at once is due to I have done the individual issue. Diagnosis. Wondering if the all did in somewhere.
If you still have starting issues maybe the regulator is bad and is bleeding off pressure?


Not understanding that last comment? :confused:
 

·
Registered
Joined
·
127 Posts
Discussion Starter #3
Lol Damn phone. For.some reason it changes words if I misspelled them. Then I look illiterate.
But I did a lunch time tune up and have found a possible large issue. That could be causing most of my problems. Short version. I need a new harmonic balancer the rubber is coming out the back side and I'm pretty sure now that the timing was off I reset it to 12 and it runs a whole lot better.
 

·
Banned
Joined
·
8,779 Posts
Lol Damn phone. For.some reason it changes words if I misspelled them. Then I look illiterate.
But I did a lunch time tune up and have found a possible large issue. That could be causing most of my problems. Short version. I need a new harmonic balancer the rubber is coming out the back side and I'm pretty sure now that the timing was off I reset it to 12 and it runs a whole lot better.
That will definitely affect it. :good:
 

·
Registered
Joined
·
127 Posts
Discussion Starter #5
Well new balancer goes in today, fingers crossed hoping its my last major issue then I can focus on rewiring under the dash and the suspension. Fyi new thread question coming soon
 

·
Registered
Joined
·
127 Posts
Discussion Starter #6
Wow am I glad I decided to change it out. when I had the puller attatched it took no pressure at all when I reached down to slide it off the outer ring came off in my hand. I also found that there was no washer inside the balanced it was just on by its own pressure. Yet again I find an issue someone else didn't take the time to do right.

ForumRunner_20121021_153706.png



ForumRunner_20121021_153852.png
 

·
Banned
Joined
·
8,779 Posts
Wow am I glad I decided to change it out. when I had the puller attatched it took no pressure at all when I reached down to slide it off the outer ring came off in my hand. I also found that there was no washer inside the balanced it was just on by its own pressure. Yet again I find an issue someone else didn't take the time to do right.
If it did not have the bolt and washer that holds it on you are lucky it didn't come off. They are not an interference fit, just slip on and need to be retained by the bolt/washer.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #8
I was amazed. No damage to the shaft car runs noticably better timing was off I'm running at a legit 12 now after a few days I'm gonna try 14 just to see.
 
1 - 8 of 8 Posts
Top