Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter #1
I can't match this to one on the chart. Can someone chime in ASAP an tell me what this means?

image-391433977.jpg



image-2759178060.jpg



image-3560698766.jpg

It looks slightly white in color, but no real deposits. Is it ok?
 

·
Registered
Joined
·
254 Posts
Discussion Starter #3
I mean It doesn't seem to have a problem, but the last time I put it together my tuning was a turn of the distributor and fpr adjustment in my garage lol. So just wanted to see if it was showing a bad sign
 

·
Registered
Joined
·
1,563 Posts
Looks like a normal plug to me.
 

·
Registered
Joined
·
254 Posts
Discussion Starter #6
How many miles do they have on them?

Here's the tips on reading spark plugs from the Useful Information sticky...

Spark Plug Reading
I can't recall, Not very many, maybe 600 or a little more?

I mean they looked alright to me, but they were a little white. I had looked at that same sticky, and it said too hot turns them white, but it says a white deposit and some other symptoms. Mine were just a little white on the top piece (I believe thats called the electrode?)

---------- Post added at 08:20 PM ---------- Previous post was at 08:19 PM ----------

Oh and those miles included a couple runs at the track and a little hot roddin lol
 

·
Lorraine's driver
Joined
·
8,195 Posts
I can't recall, Not very many, maybe 600 or a little more?

I mean they looked alright to me, but they were a little white. I had looked at that same sticky, and it said too hot turns them white, but it says a white deposit and some other symptoms. Mine were just a little white on the top piece (I believe thats called the electrode?)


Hopefully TH can take a look at them. They seemed to resemble closer to the "normal" pic. So, you were just taking a peek...no probs?

Oh and those miles included a couple runs at the track and a little hot roddin lol
Of course, that's a must.:D
 

·
Registered
Joined
·
254 Posts
Discussion Starter #8
Well I was replacing my balancer, and took the #1 out to set TDC and was checkin it out
 

·
Banned
Joined
·
8,779 Posts
It looks ok to me. A slight rusty color on the center electrode insulator is pretty normal with the fuel we can use these days. I don't see any bubbling on the strap or any other real indications of any problems either.

Like dreamstang said to really get a good reading you have to make a WOT run and then shut the engine down pretty quickly after it to get a good reading. :good:
 

·
Premium Member
Joined
·
26,052 Posts
I used to have tons of pics of what means what.... crap I will try to find it.... this reminds me I need to check mine.... and Its a PAIN (have to remove tire to check my plug WTF)
 

·
Banned
Joined
·
8,779 Posts
I used to have tons of pics of what means what.... crap I will try to find it.... this reminds me I need to check mine.... and Its a PAIN (have to remove tire to check my plug WTF)
:cool: More, better pics than what we have in the Useful Info thread would definitely be helpful. :good:


:eek: That is a PITA having to remove a tire to check plugs. :(
 
1 - 12 of 12 Posts
Top