Mustang Evolution Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
414 Posts
Discussion Starter · #1 ·
Just got my mustang out today and took it for a drive and realized my speedometer wasn't working and also my kilometers were not going up, no matter how far I drove. And also my temperature garage is bouncing from half to cold.
Thanns
 

·
Registered
Joined
·
414 Posts
Discussion Starter · #5 ·
Went trough my fuse guide in the owners manual and I looked a the fuse 6, 10A because it matched all my problems, and bought a new fuse and it fixed everything. Thank you very much for the feedback though! Much appreciated!
 

·
Registered
Joined
·
434 Posts
I was gonna say the fuse but then I thought that was dumb since it still had power but I'm glad you got it

---------- Post added at 08:02 PM ---------- Previous post was at 08:01 PM ----------

Pretty much anything always check fuses first cuz it's the easiest thing to check and to fix
 

·
Registered
Joined
·
414 Posts
Discussion Starter · #7 ·
Yea well it wouldn't have been stupid! Cause you were right lol. But ya it's all fixed, but my temperature gauge Is still bouncing around. Why could that be? I checked my coolant levels and it's good. So I'm not sure..
 

·
Registered
Joined
·
414 Posts
Discussion Starter · #9 ·
No my engine isn't overheating, the gauge is going from cold to about 1/4 way to hot. So not even half, but I check my engine and it gets hot, but not overheating hot. So it's not cold. Nor too hot, and my coolant level is fine.
 
1 - 9 of 9 Posts
Top