Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey everyone,

Soooo I blew the engine in my automatic 2012 GT earlier this year, got a new long block from Ford, and I told the install shop that while they're at it, let's install the 4.10 gears I have sitting in the garage. I got the car back and the mechanic tells me my speedometer is way off, and I'll need to get a tune to correct it, which I already knew. I also installed a PMAS CAI, so I needed a tune anyway.

I have an SCT X3, but it's still married to the 09 GT I no longer have, so I figured I'd just buy a new device. A friend suggested I buy the nGauge and tune from Palm Beach Dyno, so I did. I get the tune back, and all is great, except there was no change in my speedometer. I tested it with GPS, and it reads a consistent 20% fast (50mph on speedo is actually 40mph, 100mph on speedo is actually 80mph, etc).

The tuner at PBD said he'd do a manual method of speedo correction for the gear ratio and tire revs per mile. I got my corrected tune, took the car out for a ride, and it made no difference at all. The speedometer still reads 20% fast.

I tried to open the tune in HP Tuners software so I could look at it, but it gives a checksum validation error. HP Tuners says the OSID is unsupported, so I guess PBD must have changed it and the tune is locked.

There's no option on the nGauge device to enter gear ratio and tire size. I contacted the manufacturer of the nGauage and they said ""As far as I know, those have to be set in the tune on the '11-'14 Mustangs as there's no Module Config available for them." It seems that's only available on 2015+ Mustangs.

So now I'm at a dead end.

Did I waste $400 on an nGauge and should have bought the SCT instead?
Maybe my vehicle speed sensor itself is off?
Would something like the Yellr Yellow Box fix my issue?

Any advice or feedback is appreciated.
 

·
Registered
Joined
·
3,726 Posts
You wasted your money on the gears actually.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Hahaha. How so? It's a lot more fun on a N/A automatic than the factory 3.15's.
 

·
Registered
Joined
·
1 Posts

·
Registered
Joined
·
3,726 Posts
Hahaha. How so? It's a lot more fun on a N/A automatic than the factory 3.15's.
Not with 1st gear in the automatic being 4.17 ratio. Plenty of gear to get you out of the hole.

I ran low 11's N/A with my auto and stock 3.15's. Let me know what you run when you get everything sorted out.;)
 

·
Registered
Joined
·
10 Posts
Your speedo error is in your TUNE. Get back to your tuner and have them to correct it. Sounds like they did nothing for you the last time.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
@Grabber Blue5.0 I run a streak of 11's behind the car at every stop light. :p

@JerryZ That seems the most likely. I appreciate your confidence. I would think that a speedo correction would be a quick and simple thing. The tuner said he did correct for it, which hasn't left me with an overall positive experience. I expected more from the reputation and experience that PBD has, which is why I was trying to think of alternate causes for the issue. But at this point, I think you're right...really wish I could just see the tune file. lol
 

·
Registered
Joined
·
10 Posts
I had the same problem with mine when I changed from 3.73 to 3.31 and had to lean on the tuner to get them to change it. After my bugging them enough, they got it right. Don't know why that has to happen but it seems to be that way. Not the same tuner either. Trust me, your tuner can get it right if they'll just do it.
 

·
Registered
Joined
·
182 Posts
I would stick with Lund, AED or VMP for tunes but thats just me. MPT is pretty good as well. You also have to tell them the brand and size tires you are running in the rear as that will affect how they program the tune for the new gears as well.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
I have another tuner (same company) that's going to look into the tune file for me, so hopefully I'll have an update soon. I had already given them the tire make, size and revs.

@willb2305 Thanks for the suggestions :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
Update: Finally got a corrected tune after 6 weeks of back and forth. Speedo is spot on with GPS now. Glad the issue was only the tune file anyway. lol
 
1 - 11 of 11 Posts
Top