Mustang Evolution Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
My 2.3L automatic is giving me trouble. Sometimes I turn it on and it begins to shake, the rpm's begin to drop and it turns off. I have to press the gas to keep it from turning off on me. When im at a stop sign or red light I have to press the brakes and the gas at the same time to keep it from turning off. Does anyone know what's wrong with it? Is it the throttle body.
 

·
Registered
Joined
·
3,858 Posts
Most likely not the throttle body. When you rev it does it seem so have a loss of power? Sputter out when you rev? Any sign of misfire?
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #7 ·
This morning I turned it on and it was fine. I waited 5 min, the rpm's lowered and rose but the car didn't turn off. As soon as I put it into drive and the rpm's lowered, it began shacking and it turned off. And now it wont start.
 

·
Registered
Joined
·
3,858 Posts
That dont seem like maf
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #9 ·
When I was buying this car the owner told me that he had only changed the sensors but, he didnt tell me which ones
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #11 ·
I got a new maf sensor and its working better.

---------- Post added at 11:54 PM ---------- Previous post was at 11:50 PM ----------

I got a new maf sensor and its working better.
Does anyone know what size pistons, fuel injectors and gears I can put in my 2.3L?
 

·
Registered
Joined
·
283 Posts
Basically keep your gears . Just throw in a posi diff . Most of our rears lol come stock 3.73 non posi . It should say on the tag in the back what you have. I put my differential from an svo . I took off its 3.45 it had original and put my gear on and bolted right on.
 

·
Registered
Joined
·
68 Posts
I got a new maf sensor and its working better.

---------- Post added at 11:54 PM ---------- Previous post was at 11:50 PM ----------



Does anyone know what size pistons, fuel injectors and gears I can put in my 2.3L?
Awesome! Glad it's working better for you
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #18 ·
My car is still doing the same thing. Sometimes when I'm driving and I'm accelerating it loses power. I have to press the accelerator constantly for it to move. Eventually it becomes normal and drives normaly. What can it be?.. The fuel injectors? I know its not the maf or the intake.
 

·
Registered
Joined
·
157 Posts
Check the idle air control valve if it has one you should also rebuild your torque converter to your transmission I had a problem before with one one of my mustangs doing that I rebuilt the torque converter and it fixed the problem that's what might be wrong with your mustang
 
1 - 19 of 19 Posts
Top