Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,230 Posts
Discussion Starter · #1 ·
Wondering why my car takes a while to start and if anyone knows why?
When I first drive it everyday it always takes a while to start up. Sometimes ill have to let off and start again then it'll start right up. And if I leave it sitting for longer than 30 minutes it'll take a while to start again as well..
U have a new starter In and my alternator reads 13.7/8 when the car is running.
 

·
Registered
Joined
·
112 Posts
All of the connections tight on the starter/alternator/battery Etc?
 

·
Registered
Joined
·
7,311 Posts
get a systems check run at any auto parts store...make sure there's no ripple happening that'd drain it
 

·
Registered
Joined
·
1,230 Posts
Discussion Starter · #4 ·
Yeah everything's good! Sometimes the little plug that goes into the alternator comes loose but I just push it back in. But that doesn't make a difference. And they've checked only code I get is the egr but that's not deleted so idk why it throws it
 

·
Registered
Joined
·
46 Posts
Yeah everything's good! Sometimes the little plug that goes into the alternator comes loose but I just push it back in. But that doesn't make a difference. And they've checked only code I get is the egr but that's not deleted so idk why it throws it
It's possible it could be a weak fuel pump or possibly a clogged fuel filter. How many miles does your car have?
 

·
Registered
Joined
·
1,230 Posts
Discussion Starter · #6 ·
It's possible it could be a weak fuel pump or possibly a clogged fuel filter. How many miles does your car have?
Lol 138xxx
It's been a daily since it was brand new and kept in the family.. But yeah possibly the fuel pump is going bad. Fuel filters fine
 

·
Registered
Joined
·
46 Posts
Lol 138xxx
It's been a daily since it was brand new and kept in the family.. But yeah possibly the fuel pump is going bad. Fuel filters fine
Yea mine has been a little touchy in the mornings every now and then. I'm gonna be replacing the pump soon along with the filter. If you replace the pump might as well replace the filter as well.
 

·
Registered
Joined
·
7,311 Posts
I didnt say get your codes read lol i said system check...that way they can test your charging and starting system
 

·
Registered
Joined
·
1,230 Posts
Discussion Starter · #9 ·
Yea mine has been a little touchy in the mornings every now and then. I'm gonna be replacing the pump soon along with the filter. If you replace the pump might as well replace the filter as well.
Oh okay yeah I guess I should just do that as well:p
 

·
Registered
Joined
·
1,230 Posts
Discussion Starter · #11 ·
So how's your stang doin? You get the problem figured out yet?
I'm pretty sure it's my fuel pump but then I'm not sure because when it's cold outside it starts like nothing:eek: but when it's hot it'll take a while but then if I turn the car off for about 5 minutes and start it again even if it's hot it'll start right up. Idk but I ordered a new fuel pump so we will see what's happening. But so far she's running and looking great!
 
1 - 11 of 11 Posts
Top