Mustang Evolution Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter · #1 ·
So I have been having issues with starting my car. The car will turn over but it acts like there is not enough to keep it going initially and will drop rpms and **** off. Sometimes if I can catch it I can step on the gas pedal to keep the rpms up and keep it from strutting off. Any and all help is well appreciated.


Sent from my iPhone using Mustang Evolution
 

·
Registered
Joined
·
34 Posts
Could be many things. Battery, air flow sensor, tune, sounds like the sensor did you just recently add a cold air intake?

Sent from my 0PJA2 using Mustang Evolution mobile app
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #3 ·
Could be many things. Battery, air flow sensor, tune, sounds like the sensor did you just recently add a cold air intake?

Sent from my 0PJA2 using Mustang Evolution mobile app

So battery is new, I just also replaced the belt tensioner because that had some movement in it and sounded like it was grinding at higher rpms. CAI has been in for a long time, the tune maybe the cause I started to notice it more after it was updated now that I think of it.


Sent from my iPhone using Mustang Evolution
 

·
Registered
Joined
·
34 Posts
Could also be mass air flow sensor going bad unplug your battery pull your mass airflow sensor out and clean it out could be that

Sent from my 0PJA2 using Mustang Evolution mobile app
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #6 ·
Could also be mass air flow sensor going bad unplug your battery pull your mass airflow sensor out and clean it out could be that

Thanks I'll give that a try.

Sent from my 0PJA2 using Mustang Evolution mobile app


Change the plugs and wires lately?

Sent from my SCH-I545 using Mustang Evolution mobile app

Yes plugs and wires were replaced to recently



Sent from my iPhone using Mustang Evolution
 
1 - 6 of 6 Posts
Top