Mustang Evolution Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,161 Posts
Discussion Starter #1
Think one of my subs has blown and it's causing both not to work if I buy a new exact same sub and replace it will they both working again? Is there anyway they are wired that way or are they both blown?
 

·
Banned
Joined
·
2,785 Posts
NicholasP said:
Think one of my subs has blown and it's causing both not to work if I buy a new exact same sub and replace it will they both working again? Is there anyway they are wired that way or are they both blown?
Yes check the fuse and if have an aftermarket amp check the fuse(s) in it, also make sure if you have an aftermarket amp make sure it is turning on. Good luck!
 

·
Registered
Joined
·
525 Posts
Think one of my subs has blown and it's causing both not to work if I buy a new exact same sub and replace it will they both working again? Is there anyway they are wired that way or are they both blown?
When you blew the one sub,,that probably drop the resistance in the circuit,,which causes higher amps,,which could have blown the fuse..Or maybe if they are tied in series,,it would be like the old christmas lights,,when one goes out they all go out
 

·
Registered
Joined
·
624 Posts
mymustang said:
When you blew the one sub,,that probably drop the resistance in the circuit,,which causes higher amps,,which could have blown the fuse..Or maybe if they are tied in series,,it would be like the old christmas lights,,when one goes out they all go out
+1
 
1 - 5 of 5 Posts
Top