Mustang Evolution Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have been having alot of idle issues with my fox body lately. It started right after i installed a 70mm throttle body and egr sensor. My cars idle was all over the place and it would stall at every stop. I adjusted the egr sensor and it helped a little but it would still stall. Then I installed a 255lph fuel pump and the problem got even worse. The idle would surge the moment i start the car and alot of the time it would just shut off. Sometimes it wont start so id have to turn off the fuel pump and then start it. I dont know if its to much fuel since all i have done to my car is exhaust, throttle, and cold air. Do I need a tune to fix this? Any help would be apreciated.

Sent from my SM-N9005 using Mustang Evolution mobile app
 

·
Registered
Joined
·
8,382 Posts
I wasn't aware that it's possible to adjust the EGR sensor. Do you mean the Throttle Position Sensor?

Anyway, I think that you probably need to adjust the throttle body.
Will the engine run normally if you have your foot on the accelerator and are giving it some "gas"?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Yea sorry i mean the throttle position. Yes the car runs fine while im giving it gas and i did not notice any drop in power or hesistation only the idle

Sent from my SM-N9005 using Mustang Evolution mobile app
 

·
Registered
Joined
·
8,382 Posts
Yeah, apparently you have to adjust the throttle plates with the set screw on the aftermarket throttle bodies. They need to be set so that a little bit of air flows through when the plates are "closed".
There is a link to how to properly adjust a throttle body in one of our members recent posts... cliffyk. If you can't find cliffyk's link with a search, the information is probably online somewhere if you Google it.
 
1 - 5 of 5 Posts
Top