Mustang Evolution Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
I have a 2000 Mustang and just recently I noticed that when I turn my car off the theft light either stays on or blinks at roughly a 2 second interval and does not blink rapidly as is the norm. However the my car starts and runs fine. I have tried reprogramming the ECU as well as disconnecting the battery to reset the ECU each of which did not fix the problem. Has anyone else experienced this problem? Possible causes? Any ideas how to fix this aside from taking it the the Ford dealer?
 

·
Registered
Joined
·
1,171 Posts
I have a 2000 Mustang and just recently I noticed that when I turn my car off the theft light either stays on or blinks at roughly a 2 second interval and does not blink rapidly as is the norm. However the my car starts and runs fine. I have tried reprogramming the ECU as well as disconnecting the battery to reset the ECU each of which did not fix the problem. Has anyone else experienced this problem? Possible causes? Any ideas how to fix this aside from taking it the the Ford dealer?
'Cause ya stole it...

Try using the key instead of hot wiring the car buddy!!! Lol
 

·
Registered
Joined
·
108 Posts
Discussion Starter #4
'Cause ya stole it...

Try using the key instead of hot wiring the car buddy!!! Lol
Hmmm hilarious.....not.

---------- Post added at 05:42 PM ---------- Previous post was at 05:40 PM ----------

Mine stays one once an a while to. It goes back out an works normal after a few days. I have not figured it out either.
Yeah it's definitely odd seeing as no DTCs register either. Suppose I'll just give it some time.
 

·
Registered
Joined
·
1,563 Posts
Call the cops.....lol
 

·
Registered
Joined
·
2,029 Posts
Do you have the chipped key? Because without it you wouldn't be able to start the car. Maybe someone changed the ignition on it and disabled the theft system to do so. A DIY ignition change :D


This is the chipped key that comes with our cars
 

Attachments

·
Registered
Joined
·
1,230 Posts
Do you have the chipped key? Because without it you wouldn't be able to start the car. Maybe someone changed the ignition on it and disabled the theft system to do so. A DIY ignition change :D

This is the chipped key that comes with our cars
Mines broken but still works here's the chip so you can see

image-4007483053.jpg
 

·
Registered
Joined
·
1,230 Posts
Damn did you try eating it or something? Lol but yeah, as long as the chip is connected to the key there's no problem. But once the actual chip is broken then your car won't start
Lmao no I dropped it and it broke-.- lol but yeah I need to put some electrical tape on there:p
 

·
Registered
Joined
·
108 Posts
Discussion Starter #13
Do you have the chipped key? Because without it you wouldn't be able to start the car. Maybe someone changed the ignition on it and disabled the theft system to do so. A DIY ignition change :D

This is the chipped key that comes with our cars
Yeah I have the chipped key and am the original owner of the car. Only "ignition" work I have done is change the spark plugs and wires a year or so ago so any other DIY ignition work is news to me lol.

---------- Post added at 08:12 PM ---------- Previous post was at 08:10 PM ----------

Lmao no I dropped it and it broke-.- lol but yeah I need to put some electrical tape on there:p
Ha lol dropped it??? From what the Empire State Building? That's a hell of a lot of damage just from dropping it lol.
 

·
Registered
Joined
·
2,029 Posts
Then I'm stumped :| maybe it's Ford wanting you to come back to the dealership to have their way with your wallet?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #15 (Edited)
Then I'm stumped :| maybe it's Ford wanting you to come back to the dealership to have their way with your wallet?
Ha yeahhh honestly wouldn't be that surprised. But who knows, it's probably somehow related to the new wheels and tires I just got lol. That said Nitto NT555s are epically amazing.
 

·
Registered
Joined
·
1,230 Posts
Yeah I have the chipped key and am the original owner of the car. Only "ignition" work I have done is change the spark plugs and wires a year or so ago so any other DIY ignition work is news to me lol.

---------- Post added at 08:12 PM ---------- Previous post was at 08:10 PM ----------



Ha lol dropped it??? From what the Empire State Building? That's a hell of a lot of damage just from dropping it lol.
Lol idk.-.
 

·
Registered
Joined
·
1,171 Posts
Did you mess with the overhead light console or stereo lately?

I remember that one time I had pulled the overhead cabin light fixture.... And when the motion detector sensor wasn't hooked up, the anti theft lights went crazy... But I was able to start and drive the car.

Not sure if your year has that or not. If it does, maybe a short to some sensors?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #20
Did you mess with the overhead light console or stereo lately?

I remember that one time I had pulled the overhead cabin light fixture.... And when the motion detector sensor wasn't hooked up, the anti theft lights went crazy... But I was able to start and drive the car.

Not sure if your year has that or not. If it does, maybe a short to some sensors?
Nope haven't done any work along those lines. I imagine it is a dying sensor issue though. It does not seem to be problematic yet I just don't want to find my car immobilized one day when the PATS system does finally decide to go ape sh*t.
 
1 - 20 of 26 Posts
Top