Mustang Evolution Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
My 96 has a rough idle and it's getting on my nerves when I sit at lights. I went to PepBoys and bought some throttle body cleaner only to realize that my thottle body clearly states not to clean the throttle plate because of a protective coating. The stuff I bought (penzoil) claims that it won't remove protective coatings. Should I go ahead and use it anyway? I'm hesitant because i don't have any money right now. Does anyone have any info???
 

·
Registered
Joined
·
1,895 Posts
Do this:

Take a old tooth brush, spray the TB cleaner on the tooth brush take off the upper intake duct. open the tb, stick the tooth brush in the TB then scrub it gently, scrub the TB plate too.

You would be suprised the gunk thats in there and on the plate.

check out:
http://www.232stangs.com/how_to/tips_and_tricks/

for some tips and tricks. That tip i gave you is liste there with pics.

Also: when have you done all your maintnence stuff last? Do you have a Check engine light? Have you ever within the last 3000 miles?

get back to me.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
Hey, Charles. First, thanks for your quick feedback. I have maintenanced the car farily regularly according to the Ford manual. Also, I replaced plug wires, spark plugs and even added fuel injector fluid to an empty tank. Nothin has seemed to stop my rough idle. The engine kind of rocks from left to right at idle if you were to look under the hood. Are you sure brushing won't take of the protective coating off the throttle plate. The cleaner tells me to just spray the whole can until empty. By the way, I have never had a check engine light come on. thanks again--
 

·
Registered
Joined
·
1,552 Posts
Your should really not ask the same questions in more than one forum, I moderate both the forums you asked this one in, not sure if you asked it in any more or not, but I just got down to this one.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
my bad, Rick, I thought the first time I submitted it to this forum, but then I looked at a different forum by mistake and didn't see my post so I posted another one. Dumb mistake--oops
 

·
Registered
Joined
·
1,552 Posts
Its ok, will let you slide this time man, just try not to do that so we don't answer it twice, look in V6 engines for about the same answer.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
AHHH! I cleaned my throttle body and plate with the throttle cleaner and reattached the intake afterwards, careful to secure all connections and I went to start my car and the check engine light came on!! I reset the battery to clear the codes and it hasn't come back on. Any reasons why and should I worry??? Thanks :oops:
 

·
Registered
Joined
·
1,895 Posts
never clear your codes without going to autozone to get hte code first.
Autozone reads codes for free.

I wouldnt worry about it to much, hows the car running now? Better? Worst?
Just wait and see if the light comes back on.


How exactly did u clean it, did u use a toothbrush or spray it in?

also, did u scrub hard?
 
1 - 20 of 32 Posts
Top