Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter #1
Soooo my car on start up struggles to get going and sometimes makes a blowing pop type noise out of the CAI. I took her to Advanced Auto Parts because of the check engine light that randomly came on. His code scanner said it 'could' be the timing chain, timing chain sensor, or something else... I ruled out the chain because if it had slack you could hear that kind of noise. I replaced the sensor... And the problem still occurs. Any help will be very appreciated!
 

·
It's not me, it's you.
Joined
·
6,752 Posts
The timing chain tensioner could still be holding the slack so it's not noisy but it could still be off enough to cause your problem. Do a compression test. If some cylinders psi is too high and some low, it's gotta be the chain.
 

·
Registered
Joined
·
322 Posts
Discussion Starter #3
The timing chain tensioner could still be holding the slack so it's not noisy but it could still be off enough to cause your problem. Do a compression test. If some cylinders psi is too high and some low, it's gotta be the chain.
My dad wants me to also add that once its started and then you shut it off, she fires right up when you turn the key for the second time...
 

·
Registered
Joined
·
322 Posts
Discussion Starter #8
So I changed the CPS and it came out in 3 pieces, so that fixed the check engine problem but not the starting issue. I then thought maybe it was the fuel filter so I bought/installed that and still struggles for a little bit to start. So now its down to the fuel pump... Does anybody know what LPH our stock injector system can handle??
 

·
Registered
Joined
·
1,143 Posts
How much do you have to spend? Our Stock units i believe put out 190lph, and I've got a walbro unit that's a little over 255lph. Fuel pressure at the rails should be about 40psi at all times
 

·
Registered
Joined
·
322 Posts
Discussion Starter #12
How much do you have to spend? Our Stock units i believe put out 190lph, and I've got a walbro unit that's a little over 255lph. Fuel pressure at the rails should be about 40psi at all times
This one is only $70 and the 190lph is around $120 so somewhere in that range. I'm still undecided wither to keep modding the 6er or giver her a 4.6 4v... Regardless a bigger fuel pump is needed
 
1 - 12 of 12 Posts
Top