Mustang Evolution Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
My tranny seems to make some whining noises once in a while.

Also the clutch pedal seems to have some play?

What should i do?
The clutch was replaced at 130k roughly.

Let me know.
 

·
Premium Member
Joined
·
26,052 Posts
whine/tick? only at idle goes away when you push the cluch petal in? if so its a throw out bearing, if the tranny whines just driving around flush teh fluid with soem better fluid its about all you can do also put some sound deadener around teh shifter area under the bezel it will help keep it harder to hear.

to fix the clutch you will need a quadrent and firewall adjuster and just a note teh petal needs to be adjusted so that there is ONLY a quarter inch of play before the clutch starts to engage into neutral when you push it in, not flop just set the cruise and go down the road if you can push it in more than a quarter- half an inch before the rpms start to raise then set it in teh quarter - half inch range. err just hold the gas steady if you touch the cltuch in cruise it will turn the cruise off, you are just looking to see when the rpms start to climb thats when you know its starting to engage in to neutral.
 

·
Registered
Joined
·
1,552 Posts
Clutch can still be good and throwout bearing can be bad, this happens a lot.:eek::
 

·
Registered
Joined
·
1,552 Posts
I would still have the tranny lube changed as a first thing to try, hey, it might be almost dry, sort of sounds like it, sometimes they can develope leaks.
 
1 - 8 of 8 Posts
Top