Mustang Evolution Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
I know that this isn't mustang related, but it's general transmission knowledge i believe. i will have to post a video of the noise it is makin, but it's almost like a whooshing noise. i own a 2006 Mitsubishi Eclipse 2.4L 5-speed and i had it taken to a trans shop after hearing this noise, and they told me it was the throw out bearing, not the input shaft bearing. so yesterday, me and a buddy replaced the clutch with an exedy high performance clutch, and also replaced the throw out bearing, and put it all back together and it's still making the noise. the noise is only heard when the clutch is out, and goes away when the clutch is pressed it. the sound also speeds up when in first and giving it gas at the same time as you let you the clutch. any idea's, suggestions, help? i thought it was the TOB and clutch because it was slipping right before me and my buddy replaced the clutch. be happy to add any more information if you guys need. please help!
 

·
Registered
Joined
·
3,274 Posts
Could be a pilot bearing, or an output bearing. It could also be worn gears.

Have you drained the fluid to see if there is any debris or metal flake?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #3
Could be a pilot bearing, or an output bearing. It could also be worn gears.

Have you drained the fluid to see if there is any debris or metal flake?

yeah, we drained the fluid. no metal flakes or shavings. transmission is vibrating if you put your hand on the underside while it's running
 
1 - 4 of 4 Posts
Top