Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
476 Posts
Discussion Starter #1
Hey guys my 02 GT's clutch has been feeling kind of grainy or unsmooth. It's honestly not too bad but it bothers me. My dad drove it and couldn't even notice it. Stock clutch and linkage. When engine is off it's smooth but when I drive I can feel the "grainy" feeling. At idle when I put the clutch in it is almost perfectly smooth but still not smooth as butter. Definitely more noticeable when being driven/ higher rpms. Thanks!


Sent from my iPhone using Mustang Evolution
 

·
Registered
Joined
·
1,050 Posts
wait, what? grainy when? pushing the pedal down? or while its slipping and engaging? you might have to elaborate a lot more.
 

·
Registered
Joined
·
476 Posts
Discussion Starter #4
wait, what? grainy when? pushing the pedal down? or while its slipping and engaging? you might have to elaborate a lot more.

I can feel it when it's both being pushed in and let out. Car still drives perfectly fine


Sent from my iPhone using Mustang Evolution
 

·
Registered
Joined
·
1,050 Posts
did it just start happening or was it like that when you got it? i have an 02 as well, and theres not much about it that i would use the word "smooth" to describe it.

right now mine makes a little squeak over by the clutch fork when i engage or disengage the clutch. otherwise, the only grainy feeling ive ever got was just the vibrations all together from this big engine/transmission setup of the car.
 

·
Registered
Joined
·
476 Posts
Discussion Starter #6
did it just start happening or was it like that when you got it? i have an 02 as well, and theres not much about it that i would use the word "smooth" to describe it.

right now mine makes a little squeak over by the clutch fork when i engage or disengage the clutch. otherwise, the only grainy feeling ive ever got was just the vibrations all together from this big engine/transmission setup of the car.

It didn't use to do it. I've had the car for over 2 years and I just noticed it last summer


Sent from my iPhone using Mustang Evolution
 

·
Registered
Joined
·
1,473 Posts
Clutch cable could be getting a little old and wearing/scuffing the sheath that it moves through. I know in motocross bikes, a 2 year old cable was noticably less smooth than a brand new clutch cable. Otherwise the actual linkage in the clutch pedal assembly might benefit from lube.
 

·
Registered
Joined
·
476 Posts
Discussion Starter #8
Clutch cable could be getting a little old and wearing/scuffing the sheath that it moves through. I know in motocross bikes, a 2 year old cable was noticably less smooth than a brand new clutch cable. Otherwise the actual linkage in the clutch pedal assembly might benefit from lube.

See that's what I was thinking but if it were just the cable then I would feel the unsmoothness when the car is off also right? It's perfectly smooth ol when the car is off, but when it's running is when I feel the unsmoothness.


Sent from my iPhone using Mustang Evolution
 

·
Super Moderator
Joined
·
17,951 Posts
Cable could have been replaced at some point too. If they cheaped out and used a junk cable it could be frayed. Would be a good time to do the whole max motorsports kit.
 

·
Registered
Joined
·
476 Posts
Discussion Starter #11
Cable could have been replaced at some point too. If they cheaped out and used a junk cable it could be frayed. Would be a good time to do the whole max motorsports kit.

But what I don't get is it feels perfectly smooth when the car is off. Wouldn't it be unsmooth when the car is off too if the cable is bad?


Sent from my iPhone using Mustang Evolution
 
1 - 12 of 12 Posts
Top