Mustang Evolution Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
hello friends!

i am a proud owner of a 2008 v6 mustang
since i got the car in Spet. for 11K
i have invested over 4800 in it
the upgrades started from:

window lovers
rear wheel scoops
mirror cover
billit grille
flowmaster scavnger series duals
bbk CAI
bbk 70mm TB
sct / x3 flash tuner

sadly, after all that i feel like i lost rwhp rather then gain any..

so on to the problem,
the accleration is horrible, if i floor it in 4th ill feel no torque and ater the rpms hit 3.5 thoussand the engine gets thrown into fail safe mode
with the codes that read:
tb forced closed and p2114
and say im going 55 mph
ill trow the car in netural and the rpms will just drop and then go up almost to 4000 rpm

the fix to fail safe was turning the key off and back on and it would go away..

i called bama and they didnt know wtf was going on at all
and few peple other then me had this problem.

soo please give me your input as far as what could be happning

also do you think i need to tweek the pramaters in the tuner
like the
WOT a/f ratio
global spark
etc

thanks for reading this
i just wanna see that my money was well spent becasue at the moment im not pleased at all
:-/
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
since im an idiot i put everything on at once
dk the root of the problem

but when returned to stock the same problem happens with rpms and fail safe mode

also the rpm drop and jump back up to 4000 when thrown in netural..
the tune right now is 87S and i changed the WOT a/f to +4 richer

im just not happy =[ with all the money i spent
also what does the global spark stettings adn WOT a/f and toehr options mean???
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
i actually did that... the result was a non aggresive sound at start up / accleration. isnt there any way to fix the problem?? becasue reading up on there ppls problem with bbk Tb i was assuming it is the problem
but when i put my stock TB on it doesnt sound or perform as good

also it didnt clear up the problem
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #8 ·
i assumed so since alot of the older forms said so
smh is there a way to fix it with a tune ? because i returned the tune back to stock and omg the rpms are flying all over then damn gauge

i really hope there is a fix to it
if not itll be a waste of 370 bucks :(
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #12 ·
If your worked fine

Y is mine causing me problems, like this is the second tb am.com has sent me and its causing the same problems
And is there a way to fix it??
Also what else can I do for my v6 ??
 

·
Premium Member
Joined
·
5,424 Posts
If you have a gt500 why would you have spent any of the extra money on the v6 ?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #18 ·
Gas Ain't cheap plus bought the v6 first

Love it just as much as Shelly

---------- Post added at 04:21 AM ---------- Previous post was at 04:20 AM ----------

**** I didn't answer yur question I just like cars it's a sad fact TNT I'm not happy for money I spent on the v6
 

·
Premium Member
Joined
·
5,424 Posts
If it didn't run like poop before the mods then I'd remove them and start from there. Also When you got all the mods done did you include them for your custom tunes on the tuner or no?
 

·
Premium Member
Joined
·
5,424 Posts
You also said it threw the code P2114. That could be a bad throttle position sensor? That's one of the very first things I had to change on my 2005 stang.
 

Attachments

1 - 20 of 24 Posts
Top