Mustang Evolution Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Car idles fine and runs decent until about 3000 rpms where a vibration is felt through the pedal and car. I have a tubular k member and other than that everything is stock. One thing that was weird about the k member I got,was that we had to shave half of the bolt off at the top so it would mount onto the car. also we had to pull the steering shaft out to meet up with the rack&pinion. I didnt think much about it at the time cause I didnt know much about cars, but as I have had this car for 11 years and it never been right the whole time it makes me wonder. We put a new flywheel, new clutch,new dampner and all with little to no progress. My thought was that because the geometry of the car was moved forward with the k member that seems to be wrong could the driveline be not all the way seated in the tranny? I dont know please help me so I wont leave Mustangs forever thinking that they are cursed.
 

·
Registered
Joined
·
434 Posts
Throwing parts at a problem is not the way to fix a car. You need to go back and triple check anything you did to the car when the vib started. If you don't know what you are doing, get someone that knows. You should not have need to extend the steering shaft, some shafts need an adapter, did yours? what did the instructions say to do.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Just asking for any suggestions, I bought the k member off of a buddy and he didn't have the instillation instructions. I took it to a professional shop and they told me to do the flywheel,clutch, and dampner so that's where I am nowhere .
 

·
Banned
Joined
·
776 Posts
How old are your tires?

---------- Post added at 10:13 PM ---------- Previous post was at 10:12 PM ----------

I had one tire that was dry rotted and out of whack and I had similar vibrations. You've replaced pretty much anything else that might cause that.
 
1 - 5 of 5 Posts
Top