Mustang Evolution Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
I just fucking mishifted, and fucked something up.... I berely limped my way home.

I mis-shifted into 2nd, bounching off my revlimiter - and something broke. I think I heard a pop... Right now my car sounds like a motorcycle, like a fucking harley - literally. When RPMs go below 1,500 (in neutral, or idle) the motor just slows down, and the car dies. When driving, it's berely pulling, and I smell exhaust. I think I smelled some burning oil in it too, it smells like a damn go-cart exhaust. The motor shakes.

Ain't that a *****?
 

·
Registered
Joined
·
145 Posts
Discussion Starter #7
Nope, no warranty... I mis-shifted many times before, but I guess the 9lb flywheel really contributed this time. My RPMs climb really fast. I didn't even know what happened at 1st, I'm was just rolling without powersteering, with my car off, and the 'check engine' light on, into this parkinglot. Started it up again, and was just like "Oh.. ****.."

I talked to some people, they said in a good case - I blew out some gaskets, in the worst - bent some valves. Either way, both suck. Looks like I got a loooot of work on my hands.
 

·
Registered
Joined
·
44 Posts
.:DarkEntity:. said:
Nope, no warranty... I mis-shifted many times before, but I guess the 9lb flywheel really contributed this time. My RPMs climb really fast. I didn't even know what happened at 1st, I'm was just rolling without powersteering, with my car off, and the 'check engine' light on, into this parkinglot. Started it up again, and was just like "Oh.. ****.."

I talked to some people, they said in a good case - I blew out some gaskets, in the worst - bent some valves. Either way, both suck. Looks like I got a loooot of work on my hands.
it sounds like you bent valves, i dont think you blew any gaskets
 

·
Registered
Joined
·
1,895 Posts
My guess is that he did a little from column A, anda little from column B.
In Either case, Valves or gaskets, you're gonna have to replace gaskets anyway... cuz you have to replace gaskets to get to the valves anyway.

Sucks Alex... next time... stay away from that rev limiter :p :oops: :rolleyes: :no:
 

·
Registered
Joined
·
145 Posts
Discussion Starter #11
Well, me and this smart mechanic guy are about to go, and check it out in the daytime.......
I'll let you guys know what we find

*corss your fingers*
 

·
Registered
Joined
·
414 Posts
Good luck dude, that blows.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #16
Ok..... update:

Me and this super-smart machanic dude just finished taking my **** apart. We drained all the oil, and coolant (there was no cooland present in antifreeze, nor the other way around) took off the manifold, opened up the rear head, and now trying to get to the rear.. uhh.. I think it's called exhaust manifold in english. The only thing that stopped us, was - we lost the damn 12mm socket for the wrench, so I'll have to buy one tomorrow morning and continue. We're 90% sure that none of the valves were damaged. We narrowed down the problem to either: (best) burnt out, and busted rear exhaust manifold seal, or (worst) crack in the rear somewhere - in which case I'll have to find an engine lift, pull the whole fucker out, and fix it. Regardless, it looks like the car is going to live - the guy who's working with me (and actually telling me WTF to do.. :D ) is like a genious engineer, and a certified professor of some sort of advanced mechanics. Tomorrow once I get ahold of another 12mm socket, we will know for sure what the problem is. Ok... that looks like that's all that happened today.. :)

Alex
 

·
Registered
Joined
·
145 Posts
Discussion Starter #18
Also: I figured out why the hell was I running so much slower than I should have been with this engine... I guess we were slacking off when we dropped the motor in - what I found durring this pull-apart session was: a lot of vacuum hoses, and even the valve cover WAS NOT ON TIGHT. That means - I was losing compression, and had all sorts of pressure leaks all over that place. That really explains why I was running a lot slower than one of my friends who has the same motor as me, with the same mods. All this time I thought it was my fucking shifting, and launches - that wasn't it. :) Looks like this time, we're gonna finally do everything RIGHT, and I'll be running like I should be... :thumbsup: Can't wait
 

·
Registered
Joined
·
414 Posts
I said it once and I'll say it again, good luck. 8)
 
1 - 20 of 27 Posts
Top