Mustang Evolution Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
658 Posts
Discussion Starter · #1 ·
Ok so, im driving down the street, going from 3rd to 4th gear, as soon as i let out the clutch in 4th the whole car jerks forward a tiny bit and then starts slowing down like im pressing on the breaks. It starts sounding wrong, then The wrench lights up. I turned it off for about 30 seconds then crank the key once and nothing happens. I do it again and it turns back on. It runs and the light is off but i feel like theres a loss in power and it seems like im pressing on the breaks a little bit when i let off the gas and coast.

Any ideas whats going on?
 

·
Registered
Joined
·
47 Posts
O that's really weird then, well those are really the only things I would think of with out a more in depth look, hopefully somebody here has had this issue with such low miles and can be of better assistance
 

·
Registered
Joined
·
658 Posts
Discussion Starter · #7 ·
O that's really weird then, well those are really the only things I would think of with out a more in depth look, hopefully somebody here has had this issue with such low miles and can be of better assistance
Yeah i think were going to replace the fuel filter and see what happens after that. Thanks for the help though!
 

·
Registered
Joined
·
158 Posts
If it only happens in 4 th. try skipping up to 5 th and see what happens. Likely it's the 4 th gear synchro gear
 

·
Registered
Joined
·
158 Posts
Yep up or of the lake
 

·
Registered
Joined
·
460 Posts
Ok so, im driving down the street, going from 3rd to 4th gear, as soon as i let out the clutch in 4th the whole car jerks forward a tiny bit and then starts slowing down like im pressing on the breaks. It starts sounding wrong, then The wrench lights up. I turned it off for about 30 seconds then crank the key once and nothing happens. I do it again and it turns back on. It runs and the light is off but i feel like theres a loss in power and it seems like im pressing on the breaks a little bit when i let off the gas and coast.

Any ideas whats going on?
Does it seem like the engine is like cutting off or starving for gas? Does it idile normal? It could be the injectors/valves or just a simple fuel pump. Also check the brakes they could be stuck a little bit when cold
 
1 - 20 of 21 Posts
Top