Mustang Evolution Forum banner

21 - 35 of 35 Posts

·
Registered
Joined
·
900 Posts
Perfect name for the next product... Miracle Go!
Sounds like someone is fishing for an add for JMS PedalMAX?
 

·
Registered
Joined
·
900 Posts

·
Registered
Joined
·
900 Posts
I have JMS PeDal Max for sale.... Cost $300 sell $200 shipped OBO
How’d it work? From a guy selling, should be the best thing since sliced bread right!?
 

·
Registered
Joined
·
7 Posts
I have a 14GT. Love the car except for one annoying trait. The "lag" when you hit the pedal. Any one tried anything that actually works?
Had the same problem with my 2013 GT, even with the ProCal installed FRPP tune, until I tried what jammess posted. Turning of the Traction Control worked, and it's FREE!
 

·
Registered
Joined
·
77 Posts
Had the same problem with my 2011 GT/CS and the answer is to simply turn off the traction control (TC) immediately after start-up and leave it off. The local Ford dealer told me this and it works. With TC left on and you hit the gas a little hard from a stop the ECU interprets this action as possibly causing a loss of traction so the ECU dumps the ignition momentarily thus the lag. Now I always turn off the TC as well as overdrive. I have the automatic trans version. The local Ford dealer has a shop foreman that actually knows something about cars, just really good guys there.
+1

I have a 2011 GT as well. Hill Assist = ON and Traction Control = OFF.
 

·
Registered
Joined
·
900 Posts
How’d it work? From a guy selling, should be the best thing since sliced bread right!?
Sorry
.....
Worked very well, actually too well on my Boss. Found I didn't really need it.
If you didn’t need it then it doesn’t sound like it worked at all?
 

·
Registered
Joined
·
390 Posts
Discussion Starter #31 (Edited)
Had the same problem with my 2011 GT/CS and the answer is to simply turn off the traction control (TC) immediately after start-up and leave it off. The local Ford dealer told me this and it works. With TC left on and you hit the gas a little hard from a stop the ECU interprets this action as possibly causing a loss of traction so the ECU dumps the ignition momentarily thus the lag. Now I always turn off the TC as well as overdrive. I have the automatic trans version. The local Ford dealer has a shop foreman that actually knows something about cars, just really good guys there.
I shut TC off as soon as I start the car. But that slight lag is still there. I have an automatic by the way.
 

·
Registered
Joined
·
477 Posts
Hey there I put a thing on my pedal called a Sprint Booster. It has several different settings for your gas pedal and it actually feels like the car has more hp than it does. I used on on a mercedes I owned also. Look at sprintbooster.com you won't be sorry.
This is what I have on my 14 GT and it worked. No more throttle lag and the car feels stronger. I leave mine at 100% and took off the adjustment cable and knob. It is slightly expensive though.
 

·
Registered
Joined
·
900 Posts
21 - 35 of 35 Posts
Top