Mustang Evolution Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Hello all,
I'm back with another issue. My drivers side window stopped working completely as well as my rear drivers side quarter window. I read a couple of forums and found out that I can remove the window motor and replace the bushings..and that should solve the problem. I did so, but once I mounted the motor back on the mount, I noticed the mount was no longer in the correct position. The spring tension in the center was no longer in place and I now cannot move the mount back in the correct position. I have attached a picture, so you can get a visual.

One picture is the way it is supposed to be positioned and the other is how mine is now positioned. I am unsure of how to keep the tension on the mount without it collapsing back..I am not certain but is there a piece that I might have misplaced that holds the tension of the mount in place. Any help or suggestions would be appreciated. Thanks.
 

Attachments

·
Registered
Joined
·
33 Posts
Discussion Starter #3
Thanks for the reply, but I wasn't clear on what exactly you suggested I should do. No worries though, I gave in and decided to just order a new window regulator motor since I didn't get any other responses to my inquiry. I guess this is a topic that not too many are familiar with. Again, thanks for your response.
 

·
Registered
Joined
·
2 Posts
just recieved this issue on mine. If you had this situation again would you change them yourselves again or just take it down to the shop
 
1 - 4 of 4 Posts
Top