Mustang Evolution Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Has anyone else had the wrench light come on before. Apparently my car went into fail safe mode while driving because I practically had no power all of a sudden.
Pulled over slowly and shut off the car. When I restarted it was gone.
Only recent work done was rear gear install and a new tune.
Before restarting the car, I checked for dct codes with my tuner but it didn't give me anything.
Wondering what I need to work on because I have about 48,000 miles on it already.
 

·
Registered
Joined
·
809 Posts
You should be able to pull the code up from internal memory. If you can't then auto zone will hook up to your ECU for free, maybe they can dig it up. You need to know what the code being thrown was or your flying blind.
 

·
Registered
Joined
·
134 Posts
Mine just did it to me. Light came on, lost all acceleration and rpms jumped. I diagnosed it to be the TB. Since its cableless by turning my car off and on it reset the code. Least for me it did so I wasnt able to pull the fail code. Im having the dealer fix it since its still under warrenty.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #5 ·
Maybe I will clean my throttle body out real good then. It hasn't happened since then, but I need my car to be reliable. I might try auto zone to see if they can find a code.
 

·
Registered
Joined
·
134 Posts
ok, so i dropped my car off at the dealer on friday to investigate the engine light. Summary: light came on and lost all acceleration and rpm's jumped from 500 to 6000 and back/fourth. I was guessing the TB however since the dealer said i reset the ecu by turning the car off and on they cant diagnose the problem. Its been 3 days now and they have no clue on what to do. Ughhhh i miss her :)
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #8 ·
Aw man.. Bummer. Hope they can figure it out soon. I havent had that happen before! My dash light was in the shape of a wrench and I think yours in the check engine light? All I did was unplug the sensor and plugged it back in. Ran a different tune for a while and it went away.
I plan on buying a CAI soon anyways.
 

·
Registered
Joined
·
134 Posts
Aw man.. Bummer. Hope they can figure it out soon. I havent had that happen before! My dash light was in the shape of a wrench and I think yours in the check engine light? All I did was unplug the sensor and plugged it back in. Ran a different tune for a while and it went away.
I plan on buying a CAI soon anyways.
Yea mines the engine light. I narrowed the problem down to I believe the TB but not sure. With my back injury its impossible to do any major work on it so dealer it went. Mind you this is ths dealer who charges $400 personal tax ontop of delivery charges when you buy a car from them. $400 "sewer, dealership cleaning and water".. so I went across the street and bought mine with zero charges/taxes lol I was forced to go her cause my dealer wasnt able to fit it into his schedule
 

·
Registered
Joined
·
134 Posts
Yea mines the engine light. I narrowed the problem down to I believe the TB but not sure. With my back injury its impossible to do any major work on it so dealer it went. Mind you this is ths dealer who charges $400 personal tax ontop of delivery charges when you buy a car from them. $400 "sewer, dealership cleaning and water".. so I went across the street and bought mine with zero charges/taxes lol I was forced to go her cause my dealer wasnt able to fit it into his schedule
After 3 days of driving my car around they finally got the wrench light to come on and show its the TB failure
 

·
Registered
Joined
·
52 Posts
Usually when the check engine light comes on and the car loses all power
on a fly by wire vehicle the problem is with the fly by wire, either the pedal assemby
or the throttle body. Other trouble codes do not cause the car to barely limp along
at 10 miles per hour. The computer is programmed to do this when a fly by wire code is set
for obvious reasons, as it doesn't know if the pedal assembly is giving out erroneous data,
and it doesn't want the car going 100 miles per hour while your foot is off the gas pedal.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #12 ·
The wrench light came on a few more times and the check engine light showed up. P2111 was the code. Throttle body plate stuck open, or throttle body position sensor. Found out there is no throttle body position sensor. I need a new throttle body. Ugh... Still haven't tried cleaning it out yet.
 

·
Registered
Joined
·
134 Posts
The wrench light came on a few more times and the check engine light showed up. P2111 was the code. Throttle body plate stuck open, or throttle body position sensor. Found out there is no throttle body position sensor. I need a new throttle body. Ugh... Still haven't tried cleaning it out yet.
i just had mine replaced for the same thing.. My TB was toast and its only a year old.. Good thing for the warrenty
 

·
Registered
Joined
·
2 Posts
so guys i ran into the same issue one day it was runing fine i come home and install a 70mm bbk tb then i have these codes and it won't go iv tried everything i know i even went out yesterday and spent 110$ on parts tps and a new motor setup for it and still codes iv cleared codes done the battery. heres how i narrowed it down i unplugged the tps goes crazy okay so that works plunged in now i unplugged other side boom another code okay so i plug it back and code is gone but still have the p2111 and forced idle code has anyone solved this if i don't find out in the next few hrs im taking it to the dealer
 

·
Registered
Joined
·
441 Posts
Why don't you put your old TB back on and send the BBK one back? It appears you got a defective one. A dealer will not fix an aftermarket TB under warranty.
 

·
Registered
Joined
·
114 Posts
When you get it fix I'd like to know if it makes a performance difference?
I've read where they don't so your hands on could be helpful...
 

·
Registered
Joined
·
2 Posts
2007 mustang

problem solved today i had a strange thought and turned the spring counter clock wise and boom it worked an i had throttle all i did after was clear codes after to get rid if them and yes i did feel more low end power accidentally left tire marks in front of my house :bow::cool: btw the service advisers at rockwall ford of texas are jerks
 

·
Registered
Joined
·
1 Posts
Mine just did it to me. Light came on, lost all acceleration and rpms jumped. I diagnosed it to be the TB. Since its cableless by turning my car off and on it reset the code. Least for me it did so I wasnt able to pull the fail code. Im having the dealer fix it since its still under warrenty.

What did they fix on it? Was it the throttle body because my 2016 mustang is doing it now. Rpm's are jumping and it won't get power at times. My wrench light is on saying see manual.
 

·
Registered
Joined
·
1 Posts
I have a 6 speed 2014 mustang v6, and kind of have the same problem!!! When I am at a complete stop like stop my car idles weird it sets at 600k rpms then goes up to 1000k rpms then goes back to 6 and back to 1k & etc. my car also has also been like bogging in a way when I'm driving it sucks lol. I just recently got the wrench light on my gauge cluster, I did alot of research and I'm figuring its my throttle body that's causing this problem. I have a 73mm bbk throttle body and have a quick question should I just buy a new one? like that is all I can think about lmk if you ever fixed your problem , thanks !
 
1 - 20 of 21 Posts
Top